Subject: Re: [6pack] Grease gun

From: [email-masked]
Date: Tue, 15 May 2012 23:28:08 +0000

I have a Lincoln pneumatic grease gun.
It comes with a long flexible hose to the nozzle, like the one in your link, but longer.
I don't have issues with it leaking.
I got it because I have a farm with several tractors and do a LOT of greasing, like every weekend. The hand lever guns were killing me!

The great thing about this Lincoln is the trigger is easy to pull and leaves your other hand free to lock (and sometimes hold) the nozzle down on the zerk fitting.
The hose is flexible enough to get into tight places and stiff enough to shove on to recessed fittings (man I hate those).

The other great thing is that it has the power to blow through most stuck fittings.

the quality is outstanding. I have had no issues and have dropped it a couple of times with not even a scratch.
The pull back latch is easy to engage and very positive.

You will fall in love with it and wonder why it took you so long to get it. Kind of like your first air ratchet.
You will also end up greasing things more often, just to use it. That's a good thing.

They make a battery powered one, if you don't have a compressor. But hey, if you don't have a compressor then shame on you! Buy one just so you can use the grease gun.

-grego

-----Original Message-----
From: David Friedlander [mailto:[email-masked]]

 can someone recommend a good quality grease gunfor tie rods, u-joints, ball joints, etc. that is able to reachgrease zerks while lying on ones back on the floor of agarage? :- )

________________________________________

[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe: http://autox.team.net/mailman/options/6pack/[email-masked]

---

From: David Friedlander <[email-masked]>
Date: Tue, 15 May 2012 19:39:48 -0400

I see. Does it look something like this?

http://www.northerntool.com/shop/tools/product_200361819_200361819

Dave

On Tue, May 15, 2012 at 7:28 PM, <[email-masked]> wrote:

> I got it because I have a farm with several tractors and do a LOT of
> greasing, like every weekend. The hand lever guns were killing me!
>
> The great thing about this Lincoln is the trigger is easy to pull and
> leaves your other hand free to lock (and sometimes hold) the nozzle down on
> the zerk fitting.
> The hose is flexible enough to get into tight places and stiff enough to
> shove on to recessed fittings (man I hate those).
>
> They make a battery powered one, if you don't have a compressor. But hey,
> if you don't have a compressor then shame on you! Buy one just so you can
> use the grease gun.
>
> -grego
>
> *From:* David Friedlander [mailto:[email-masked]]
> **
>  can someone recommend a good quality grease gun for tie rods, u-joints,
> ball joints, etc. that is able to reach grease zerks while lying on ones
> back on the floor of a garage? :- )

[email-masked]