Subject: [6pack] Stromberg Upgrade?

From: [email-masked]
Date: Wed, 14 Nov 2012 14:26:49 -0500 (EST)

The original Strombergs on my '72 TR6 need some work. It occurred to me  
that this might be a good time to consider an upgrade. What's the conventional 
 wisdom on the best replacement? I'm leaning toward the HS6 replacement kit 
with  K&N filters. The best price appears to be from Victoria British.
 
Has anyone installed the HS6 kit? Any thoughts, caveats, considerations? 
 
Thanks for any input!
 
Steve, Vacaville, CA
'72 Damson

________________________________________

[email-masked]

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/6pack/[email-masked]

---

From: [email-masked]
Date: Wed, 14 Nov 2012 21:44:24 -0500 (EST)

Thanks! Are those K&Ns?

[email-masked]

---

From: "Greg Lemon" <[email-masked]>
Date: Wed, 14 Nov 2012 20:50:13 -0600

No just stock TR4A paper elements

I also have some big velocity stacks for when I want to go fast, zoom zoom.

Greg

  ----- Original Message -----
  From: [email-masked]
  To: [email-masked] ; [email-masked] ; [email-masked]
  Sent: Wednesday, November 14, 2012 8:44 PM
  Subject: Re: [6pack] Stromberg Upgrade?

  Thanks! Are those K&Ns?

[email-masked]