Subject: Re: [6pack] Stromberg Upgrade?

From: "Greg Lemon" <[email-masked]>
Date: Wed, 14 Nov 2012 19:32:02 -0600

I fit 175 CDs to my TR250, much simpler and easier to set up right than the 
CD2s, no emissions valves etc. and still look original at a quick glance.

http://i207.photobucket.com/albums/bb196/grglmn/newcarbs.jpg

Cost me about $150 for some used carbs and a comprehensive rebuild kit.

Greg Lemon

________________________________________

[email-masked]

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/6pack/[email-masked]

---

From: Joe Alexander <[email-masked]>
Date: Wed, 14 Nov 2012 20:38:40 -0500 (EST)

That would be my first choice.....

Excellent....

-----Original Message-----
From: Greg Lemon <[email-masked]>
To: TR6UO <[email-masked]>; 6pack <[email-masked]>
Sent: Wed, Nov 14, 2012 7:35 pm
Subject: Re: [6pack] Stromberg Upgrade?

Greg Lemon

[email-masked]

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/6pack/[email-masked]

[email-masked]

---

From: David Friedlander <[email-masked]>
Date: Thu, 15 Nov 2012 16:49:11 -0500

Steve;

Of course, if you want better gas mileage and to be able to quit tweaking/
more tweaking/adjusting your carbs, there's Throttle Body Fuel Injection!
I've had it for years and would never consider going back.

See details at http://www.pattonmachine.com/

The carbs can remain stock appearance from the outside, if you wish,
and the K&N's sold by TRF and others fit great!

NFI....

Dave Friedlander
'74 Six w/TBI and A-type OD

On Wed, Nov 14, 2012 at 2:26 PM, <[email-masked]> wrote:

> The original Strombergs on my '72 TR6 need some work. It occurred to me
> that this might be a good time to consider an upgrade. What's the
> conventional
>  wisdom on the best replacement? I'm leaning toward the HS6 replacement kit
> with  K&N filters. The best price appears to be from Victoria British.
>
> Has anyone installed the HS6 kit? Any thoughts, caveats, considerations?
>
> Thanks for any input!
>
> Steve, Vacaville, CA
> '72 Damson
>
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe:
> http://autox.team.net/mailman/options/6pack/[email-masked]

[email-masked]