Subject: [6pack] (no subject)

From: kirsis stephen <[email-masked]>
Date: Mon, 29 Apr 2013 07:02:00 -0400 (EDT)

Dave, Do-not have the Wix # but I highly recommend the K and N because of the 
ease of getting it on or off with the 1" wrench nut. #HP-2009. Cross references to 
FRAM PH3600/DG3600. Purolator L20195/ L35098.
Steve Kirsis '70 Damson

________________________________________

[email-masked]

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/6pack/[email-masked]

---

From: David Fidler <[email-masked]>
Date: Mon, 29 Apr 2013 07:45:10 -0400

Just make sure it has the bypass valve in it. When you change to a spin on,
you lose this feature, so you need a replacement filter with it built in.

There are several threads on the 6-pack forums about this, including numbers
etc.

Best regards,

David.

Sent from my iPhone

On Apr 29, 2013, at 7:02 AM, kirsis stephen <[email-masked]>
wrote:

> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe:
http://autox.team.net/mailman/options/6pack/[email-masked]

[email-masked]