Subject: [6pack] Tri carb set up

From: kingr44916--- via 6pack <[email-masked]>
Date: Sat, 14 May 2016 06:33:24 -0400

--===============5694567325158433530==
	boundary="----=_Part_136121_754569806.1463222004747"

------=_Part_136121_754569806.1463222004747
Content-Transfer-Encoding: 7bit

Anyone running with the Goodparts tri carb Stromberg set up is it worth it on a stock motor any advice is great
------=_Part_136121_754569806.1463222004747
Content-Transfer-Encoding: 7bit

<font color='black' size='2' face='arial'><font style="background-color: transparent;">Anyone running with the Goodparts tri carb Stromberg set up is it worth it on a stock motor any advice is great</font></font>
------=_Part_136121_754569806.1463222004747--

--===============5694567325158433530==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/6pack

--===============5694567325158433530==--

---

From: glemon--- via 6pack <[email-masked]>
Date: Sat, 14 May 2016 14:17:48 +0000

I dont have it on my car, and if you want a simple bolt on that looks good and may give a little more power I am sure it will do the trick.  If your goal is to make the car quicker, you will get more bang for the buck getting the head shaved to get about 9.5/1 compression, getting a mild regrind on the cam, and, if you have the engine or tranny out shaving some weight off the flywheel.  All can be done for less than the the cost of the triple manifold set with carbs.  Of course there is also more work and down time involved.

That is how my car is set up, I got a chance to run an electronically timed quarter mile a couple years back.  Consistent 16.7s, vs. Road and Track's time for a stock TR250 of 17.9.  It purrs like a kitten and pulls great out of tight corners.

If you want them cause you want them do it.  You can always do more upgrades later :).  

Greg Lemon
68 TR250
---- dave n via 6pack <[email-masked]> wrote: 
> absolutely!  I put my triple carbs on a stock motor, and the increased torque was immediately noticeable.  you are effectively adding 50% more carburation.  think about that!  now the downside is that it will make you yearn for a mild cam and other engine mods!  and then suspension mods to handle it, brake mods to stop it, etc.  I totally went that route and never regret a minute!  plus my son loves the car.
> 
> From: kingr44916--- via 6pack 
> Sent: Saturday, May 14, 2016 5:33 AM
> To: [email-masked] 
> Subject: [6pack] Tri carb set up
> 

[email-masked]

---

From: Gene Holtzclaw via 6pack <[email-masked]>
Date: Sat, 14 May 2016 20:28:01 +0000

--===============8947136770599918038==
Content-Language: en-US
	boundary="_000_BY2PR15MB037695698DD1642F72A5D89EE1750BY2PR15MB0376namp_"

--_000_BY2PR15MB037695698DD1642F72A5D89EE1750BY2PR15MB0376namp_
Content-Transfer-Encoding: base64

--_000_BY2PR15MB037695698DD1642F72A5D89EE1750BY2PR15MB0376namp_
Content-ID: <[email-masked]>
Content-Transfer-Encoding: base64

--_000_BY2PR15MB037695698DD1642F72A5D89EE1750BY2PR15MB0376namp_--

--===============8947136770599918038==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============8947136770599918038==--

---

From: Ted Schumacher via 6pack <[email-masked]>
Date: Sat, 14 May 2016 19:04:02 -0400

--===============0239588997133852545==
        boundary=--_com.android.email_1444574603116116_alt

----_com.android.email_1444574603116116_alt
Content-Transfer-Encoding: base64

----_com.android.email_1444574603116116_alt
Content-Transfer-Encoding: base64

----_com.android.email_1444574603116116_alt--

--===============0239588997133852545==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============0239588997133852545==--

---

From: glemon--- via 6pack <[email-masked]>
Date: Sun, 15 May 2016 4:08:51 +0000

Maybe not fair, but I was using the number for the manifold and three carbs, which was something like $1600, I agree with the guy who suggested the emission strombergs are not as easily tuneable as early SUs or even early strombergs.

I did have my flywheel lightened locally, for about $70 if I recall right, shop run by old timers who charge old time prices, can look up bearings and seals and even brake shoe linings in real books with specs, rather than being lost without make and model, but I digress, I trust them and the work they do.

Cam and lifters redone at Delta cams for about $120, dont know the exact cost of the head, it was done with the rest of the motor, and the cost will vary depending on what else "while you have it off and apart".

I have another head I am going to go with for a lttle higher compression and cleaned up the ports, interested to see what that will do.  I have read 9.5 or 10.0 to 1 is about as high as you want to go with a street motor, but no personal experience other than with my own motor, I was thinking 10 to 1 with the new head, but you have me thinking I might bump it a little more.

Greg Lemon 
---- dave n via 6pack <[email-masked]> wrote: 
> I'm curious - the manifold kit is $399.  add $100 for another carb (and 
> that's high), and you are at $499.  you are saying you can have the head 
> shaved, get a mild cam, and add a lightened flywheel for less than $500?????
> 
> camshafts are in the $200 to $300 range, then you have to change out tappets 
> or have them cut.  maybe you can get the head shaved for under $200, but if 
> you have it out you should have it redone, or at least checked out.  adding 
> that pressure and you really should get a better head gasket.  add some 
> miscellaneous stuff and you are well over $500.
> 
> buying a lightened flywheel is $300 to $500.  I guess you could have yours 
> lightened for less, but it better be by someone who really knows what they 
> are doing.  if a flywheel grenades it will take off your foot.
> 
> I don't see how your numbers work unless you have a machine shop and you did 
> all this yourself.
> 
> and, btw, no reason to stop at 9.5 to 1.  you can run close to 11 on these 
> cars.  I'm over 10 and I know Richard Good is over 12 on his car with no ill 
> effects.
> 
> -----Original Message----- 
> From: [email-masked]
> Sent: Saturday, May 14, 2016 9:17 AM
> To: dave n
> Cc: dave n via 6pack
> Subject: Re: [6pack] Tri carb set up
> 
> I dont have it on my car, and if you want a simple bolt on that looks good 
> and may give a little more power I am sure it will do the trick.  If your 
> goal is to make the car quicker, you will get more bang for the buck getting 
> the head shaved to get about 9.5/1 compression, getting a mild regrind on 
> the cam, and, if you have the engine or tranny out shaving some weight off 
> the flywheel.  All can be done for less than the the cost of the triple 
> manifold set with carbs.  Of course there is also more work and down time 
> involved.
> 
> That is how my car is set up, I got a chance to run an electronically timed 
> quarter mile a couple years back.  Consistent 16.7s, vs. Road and Track's 
> time for a stock TR250 of 17.9.  It purrs like a kitten and pulls great out 
> of tight corners.
> 
> > absolutely!  I put my triple carbs on a stock motor, and the increased 
> > torque was immediately noticeable.  you are effectively adding 50% more 
> > carburation.  think about that!  now the downside is that it will make you 
> > yearn for a mild cam and other engine mods!  and then suspension mods to 
> > handle it, brake mods to stop it, etc.  I totally went that route and 
> > never regret a minute!  plus my son loves the car.
> >
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Forums: http://www.team.net/forums
> 
> [email-masked]
> Unsubscribe/Manage: http://autox.team.net/mailman/options/6pack/[email-masked]
> 

[email-masked]