Subject: Re: [6pack] 6pack Digest, Vol 46, Issue 10

From: Luis via 6pack <[email-masked]>
Date: Thu, 13 Sep 2018 14:47:21 -0500

Yeah I tied a pair of goose jets during the rebuild, both leaked within 100 miles.  Put the old needles back in and they are still holding 10 years later. I think key is put a filter before the fuel pump and another before the carbs - they're cheap. 

Lou
72 Pimento

> On Sep 13, 2018, at 2:31 PM, mohawktriumphs <[email-masked]> wrote:
> 
> lou,
> same thing happened to me . carb throats had gas puddles , oil readings increasing(!) , fuel odors , . solution : junked the grose jets ,reset floats = nirvana . . .
> 
> 
> 
> Sent from my ASUS Pad

_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/6pack

---

From: Richard via 6pack <[email-masked]>
Date: Fri, 14 Sep 2018 08:25:10 -0700

Any brand of float level control valves will not stop fuel from passing if some sort of debris is allowed to stick between the mating surfaces. The idea is to filter the fuel so this can't happen. No news here, right?! I know the Grose Jet is thought poorly of by some on these forums, but I can attest to having only one incidence of failure in the 33 years I've used the Grose. One piece of rubber about the size of a piece of rice got thru. Likely my fault since I had peviousy changed a fuel line, after the filter. 
Dick

> On Sep 13, 2018, at 12:47 PM, Luis via 6pack <[email-masked]> wrote:
> 
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.96
> Forums: http://www.team.net/forums
> 
> [email-masked]
> Unsubscribe/Manage: http://autox.team.net/mailman/options/6pack/[email-masked]
> 

[email-masked]

---

From: Luis via 6pack <[email-masked]>
Date: Fri, 14 Sep 2018 10:38:44 -0500

Yeah it’s not the old Grose jets that have been found to be unreliable, it’s the new ones you buy today. QC?

I’ve had the original needle jets in my car since purchased 10 years ago. Put them back in after the new Grose jets that failed from the carb rebuild.  Who knows how long before that. 

Key is filtering.  

Lou

> On Sep 14, 2018, at 10:25 AM, Richard <[email-masked]> wrote:
> 

[email-masked]

Unsubscribe/Manage: http://autox.team.net/mailman/options/6pack/[email-masked]