Subject: [Bricklin] 351w oil filter

From: Mike Walsh <[email-masked]>
Date: Tue, 27 Nov 2012 20:12:47 -0500

Friends:

Any idea what size oil filter the 351w takes?

Thanks!

Mike Walsh

Sent from my iPhone
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: Steve Stratton <[email-masked]>
Date: Tue, 27 Nov 2012 17:29:13 -0800 (PST)

Mike,

I use the Motorcraft FL-300. Most auto parts stores have it or can order it.

Steve Stratton
Bricklin VIN&#39;s #2856 & #2889
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive