Subject: [Bricklin] Bricklin Radiator

From: dmcturbo turbo <[email-masked]>
Date: Wed, 21 Jan 2015 00:28:44 -0500 FILETIME=[1FC3E9A0:01D0353B]

Hello all, it has been a long time since I checked in with
the group ( I
am not sure I even remember how to post to the group) I hope you
are all doing
well.

I need to replace the Radiator on my 1975 Brick , it is a
low milage
(only 4K Mi) all original car.

I seem to recall that if you ordered a
radiator for a 1974
amc matador with the v8 that was the replacement part .
Can anyone tell me if
that radiator is a drop in replacement or what was used
as the original
radiator?

Since the car is all original and not driven much I
think I
would like to try and keep it original if I can.

1.      
So is 74 l
the AMC  Matador radiator the same one that is in the
car now?

2.      
Is
the
AMC radiator drop in form fit function or does it need to be modified?

3.
Is there a standard radiator available or is it
unique to the Brick?

4.
What are people using in stock Bricklins for
radiators now?

5.      
I have
new upper and lower radiator hoses, I
will replace the thermostat and other
recommendations if I try to tackle this
job?

Thank you for your help!
Mike D.

1557 in NY
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: Dennis <[email-masked]>
Date: Wed, 21 Jan 2015 11:10:31 -0600

If you'd like to keep it as original as possible I would suggest checking
into getting the original one rebuilt...there will be no question of it
dropping right back in.  While it can be a little more expensive to go this
route, at least you'll know you're still as close to original as possible
with a fully refurbished and tested radiator.

Dennis
#274

On Tue, Jan 20, 2015 at 11:28 PM, dmcturbo turbo <[email-masked]>
wrote:

> Donate: http://www.team.net/donate.html
> Suggested annual donation  $11.47
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/bricklin/[email-masked]

---

From: "Rick at High Tech Coatings" <[email-masked]>
Date: Wed, 21 Jan 2015 12:39:30 -0500

There is no "drop in" replacement, there are few that are close, if you want
to keep it original have your original recored, The top tank is a bricklin
only piece

---
This email has been checked for viruses by Avast antivirus software.
http://www.avast.com
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: Chris Fasulo <[email-masked]>
Date: Wed, 21 Jan 2015 16:27:23 -0500

I had mine refurbished in Long Island. I believe they changed the internals a
little to make it more efficient. Seems to be working great.

Chris Fasulo

> On Jan 21, 2015, at 12:39 PM, Rick at High Tech Coatings
> This email has been checked for viruses by Avast antivirus software.
http://autox.team.net/mailman/options/bricklin/[email-masked]
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: "John T. Blair" <[email-masked]>
Date: Wed, 21 Jan 2015 16:32:14 -0500

At 12:28 AM 1/21/2015, you wrote:

 >I need to replace the Radiator on my 1975 Brick , it is a low 
milage (only 4K Mi) all original car.
 >I seem to recall that if you ordered a radiator for a 1974 amc 
matador with the v8 that was the
 >replacement part .  Can anyone tell me if that radiator is a drop 
in replacement or what was used as the
 >original radiator?

Mike,

If you really want to keep the car original, sort of.  I've heard the 
same thing, but it's NOT a drop in
replacement.  The radiator is supposedly from a Matador Coupe (a 
Modean 589 need relocate the
top inlet, I've been told the 589 is NLA, but that the Modine 579 
will work.)  I've
heard that the Redi-Rad is not as good as the Modean, and that a 4 
core block too
easily use 3 core.

So don't recommend you go at this lightly.  What I did, was pull my 
radiator, and took
it to a local radiator shop and had them "re-core" it.  Which means 
they pulled the
top & bottom tanks and then put a new core inbetween.  Tell the 
radiator shop what you
think about a replacement radiator and see what they say.

If you have had any overheating problems, you might want to use one 
of the aluminumn radiators that Terry, Les, & I think Bob sell.

Maybe someone like Rick will chime in here also.

John

John T. Blair  WA4OHZ     email:  [email-masked]
Va. Beach, Va                  Phone:  (757) 495-8229

           48 TR1800    48 #4 Midget    65 Morgan 4/4 Series V (B1106)
      75 Bricklin SV1 (#0887)    77 Spitfire    71 Saab Sonett III
                        65 Rambler Classic

Morgan:    www.team.net/www/morgan
Bricklin:  www.bricklin.org

If you can read this             - Thank a teacher!
If you are reading it in English - Thank a Vet!!

 From Dennis Prager - The American Trilogy:
      e pluribus Unum, "from many, one."
      In God We Trust
      Liberty - the  power  of  choosing,  thinking,  and  acting  for
                   oneself; freedom  from  control  or  restriction

---