Subject: [Fot] TR3 oil catch can

From: Alfetta95 via Fot <[email-masked]>
Date: Fri, 12 Apr 2024 22:12:04 -0400

Amici

What are you TR3-4 guys doing for an oil catch can?  My 1qt plastic bottle wire tied to the chassis isn’t cutting it any more.  

Thanks
Todd
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Charly via Fot <[email-masked]>
Date: Fri, 12 Apr 2024 22:18:30 -0500

You can see mine in the lower left corner, tech one time told me it wasn't big enough, I took it out and showed them the 1 quart designation on the can. My car had this originally in
'85, I just updated with new can.
Charly Mitchel
TR6 #44

On Fri 12/04/24  7:12 PM , Alfetta95 via Fot [email-masked] sent:
> Amici
> 
> What are you TR3-4 guys doing for an oil catch can?  My 1qt plastic bottle
> wire tied to the chassis isn’t cutting it any more.  
> Thanks
> Todd
>