Subject: [Fot] Front and Rear springs

From: Alfetta95 via Fot <[email-masked]>
Date: Fri, 9 Jan 2026 13:44:50 -0500

Friends,

What are you TR3 guys using for front and rear springs? Mine are still from when my father raced the car 50yrs ago. Anyone using the Racetorations comp rear springs? 

I’ve ordered the Koni shocks for front and am having the rear shocks rebuilt. 

When Tony Garmey passed me in the left hander at Lime Rock I thought, “hmm that car didn’t show body roll”.  It was then I decided to have a look at mine.  

Any info is helpful 
Todd
_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Chuck Gee via Fot <[email-masked]>
Date: Fri, 9 Jan 2026 19:17:25 -0500

But he’d have more body roll!

Chuck Gee

> On Jan 9, 2026, at 4:53 PM, Steven Belfer via Fot <[email-masked]> wrote:
> 
> The problem is, you could swap cars with Tony and he would still overtake!
> 
> ~Steve
> 
> 
>> On Jan 9, 2026, at 12:01 PM, Tony Garmey via Fot <[email-masked]> wrote:
>> 
>> 
>> Sent from my iPhone
>> 
>>>> On Jan 9, 2026, at 10:58 AM, Alfetta95 via Fot <[email-masked]> wrote:
>>> 
>>> Friends,
>>> 
>>> http://www.fot-racing.com/
>>> 
>>> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
>>> 
>>> 
>> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
>> 
>> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>