Subject: [Healeys] Starter, Generator Repairs

From: Jack Feldman <[email-masked]>
Date: Fri, 20 Apr 2012 15:46:32 -0500

Peter & Veronica are spot on in their advice to look up a local auto
electric shop.

I once had an official "restorer of cars" quote $250. to rebuild a starter
for my BT7. The advice to go to an automobile electric shop is great. In
our area the one I know is Morton Grove Auto Electric which had two stores,
but only the Arlington Heights store is still open. That is in Illinois. To
them my ancient generator was just another job, and it cost me around $83
dollars to have it rebuilt and painted the correct color.

When I looked at the website I didn't see their Morton Grove location so I
call the contact number. I was told that the Morton Grove location was shut
13 years ago The means their repairs, and I also had more than one unit
rebuilt, have lasted over 13 years without failing. Obviously my $83.00
price is no longer valid.

I say this as a happy customer with no interest in them.

>From their website: We also rebuild units for owners of antique cars who
want to keep their vehicles in original condition, and for hot-rod owners
who appreciate the beauty of chromed parts.

Their web site is .cyrusnet.com/mg/. <http://cyrusnet.com/mg/>

Check around, you may have someone similar in your area.

Jack
_______________________________________________
Support Team.Net http://www.team.net/donate.html
Suggested annual donation  $12.75
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

---

From: Bob Spidell <[email-masked]>
Date: Fri, 20 Apr 2012 21:07:22 +0000 (UTC)

More than likely the 'restorer of cars' would have farmed-out the job to a local shop (and doubled the cost). 

Bob 

-------------------------------- 
Bob Spidell - San Jose, CA 

----- Original Message -----
From: "Jack Feldman" <[email-masked]> 
To: [email-masked] 
Cc: [email-masked] 
Sent: Friday, April 20, 2012 1:46:32 PM 
Subject: [Healeys] Starter, Generator Repairs 

Jack 

[email-masked]

---

From: Bob Spidell <[email-masked]>
Date: Fri, 20 Apr 2012 21:07:36 +0000 (UTC)

Bob 

----- Original Message -----
From: "Jack Feldman" <[email-masked]> 
To: [email-masked] 
Cc: [email-masked] 
Sent: Friday, April 20, 2012 1:46:32 PM 
Subject: [Healeys] Starter, Generator Repairs 

Jack 

[email-masked]

---

From: john spaur <[email-masked]>
Date: Fri, 20 Apr 2012 15:24:46 -0700

Jack,

I recently had a local autoelectric shop replace the cloth on the 
field coils. It cost around $38. I replaced the bearing and rivets 
because they did not have the original style but they could have done 
that two and I installed the new brushes - very easy stuff. They 
recommended against having the commuter turned because they can 
crack; you can check it to see how worn it is. A generator rebuild 
should cost around $100. You need the drive end bearing, commuter 
brushes, the rear bronze race and possibly the two springs that press 
the brushes against the commuter.

John

At 09:07 PM 4/20/2012 +0000, Bob Spidell wrote:
>More than likely the 'restorer of cars' would have farmed-out the 
>job to a local shop (and doubled the cost).
>
>Bob
>
>
>Unsubscribe/Manage: 
>http://autox.team.net/mailman/options/healeys/[email-masked]

[email-masked]

---

From: "E. A. Driver" <[email-masked]>
Date: Fri, 20 Apr 2012 17:00:42 -0600

Hi John

that is a price. $100, is what is have been quoted here for a generator 
rebuild
kind regards
ed
Historian, AHCUSA

john spaur wrote:
> recommended against having the commuter turned because they can crack; 
> you can check it to see how worn it is. A generator rebuild should 
> cost around $100. You need the drive end bearing, commuter brushes, 
> the rear bronze race and possibly the two springs that press the 
> brushes against the commuter.
>
> John
>

[email-masked]