Subject: [Healeys] Les Leston -

From: Jean Caron <[email-masked]>
Date: Thu, 17 May 2012 21:09:22 +0000

Listers:

Alfred Lazarus Fingleston better known as Les Leston, passed away Sunday May
13th at the age of 91. He drove Grand Prix cars in the early 1950's and was
the co-driver for the Austin-Healey 100S (NOJ 393) entry at the 1955 LeMans
but did not get the opportunity to drive due to the accident. He later made
his name by selling steering wheels bearing his name, racing gloves, helmets
and fire-retardant racing suits.

Jean Caron
_______________________________________________
Support Team.Net http://www.team.net/donate.html
Suggested annual donation  $12.75
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

---

From: Mark J Bradakis <[email-masked]>
Date: Thu, 17 May 2012 18:52:55 -0600

I seem to recall sometime in the past having a pair of SU velocity
stacks bearing his name.

And I must confess.  When I first glanced at the message I though it
was about Les Nessman, the news guy in the WKRP sitcom.

mjb.

[email-masked]

---

From: Austin Healey <[email-masked]>
Date: Fri, 18 May 2012 07:13:34 +0200

May He rest in peace!
I have a very heavy Les Leston badge on my garage-wall.

G

2012/5/18 Mark J Bradakis <[email-masked]>

> ______________________________**_________________
> Support Team.Net http://www.team.net/donate.**html<http://www.team.net/donate.html>
> http://autox.team.net/mailman/**listinfo/healeys<http://autox.team.net/mailman/listinfo/healeys>
>
> Unsubscribe/Manage: http://autox.team.net/mailman/**
> options/healeys/pajtamuvek@**gmail.com<http://autox.team.net/mailman/options/healeys/[email-masked]>

[email-masked]