Subject: [Healeys] Leadfoot festival <mailto:[email-masked]?subject=unsubscribe> <mailto:[email-masked]?subject=subscribe>

From: I Erbs <[email-masked]>
Date: Sat, 15 Sep 2012 21:36:27 -0700

Watching on speed channel. Showed a 100s qued up to run the hill.

Ira Erbs
IT Consultant
Portland, OR
_______________________________________________
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Tom Felts <[email-masked]>
Date: Sun, 16 Sep 2012 7:56:11 -0400

Saw it.

---- I Erbs <[email-masked]> wrote: 

=============

Ira Erbs
IT Consultant
Portland, OR

[email-masked]

[email-masked]