Subject: Re: [Healeys] BJ8 Speedometer Troubleshooting

From: Bob Yule <[email-masked]>
Date: Fri, 28 Dec 2012 14:16:52 -0500

Mike, I would suspect that the angle drive is broken and this is usually 
caused by the speedometer seizing up.  This is often caused by years of 
grease accumulation, which dries out and goes hard.  The cure is to 
dissmantle the speedo and give a good clean. We use brake cleaner in an 
aerosol.   Make sure the cable is in good condition, both inner and outer, 
and check or replace the angle drive.  Make sure that the joints between the 
cable and speedo, cable and angle drive and angle drive to transmission are 
in good condition.  No corners rounded off etc.
    We then calibrate the units, but it is more than I want to try and 
describe here.
    Although it is possible to remove the angledrive from underneath the 
car, with long skinny fingers, it is far easier to get at by removing the 
transmission tunnel.  Always a fun job on a BJ8.
Cheers.......Bob
Check out our web site www.autofarm.net
----- Original Message ----- 
From: "Mike Garvey" <[email-masked]>
To: <[email-masked]>
Sent: Friday, December 28, 2012 1:45 PM
Subject: [Healeys] BJ8 Speedometer Troubleshooting

>I am troubleshooting the speedometer/odometer on my '67 BJ8.
>
> The speedometer was erratic (odometer worked, though I am unsure if
> accurately) and the speedometer was "sticky", rarely going above 40 mph 
> and
> usually indicating zero.  At some point both odo and speedo stopped 
> working
> in any sense.
>
> The speedometer inner (spring) cable from the transmission does not turn
> while the car is moving; upon removal, the inner part of the cable looks
> fine: no breaks or kinks.  The end of inner cable does not turn freely 
> when
> I try to rotate it from the speedometer end, telling me that the
> transmission end of the cable is "locked".
>
> I have read the Technical  Service Bulletin (TSB) of February 29, 1968
> posted on Moss Motors and the cautionary notes about the washer.  I do not
> (yet) know if this washer is present.
>
> I have read (some of) the archives going back to 2004 or so to see if 
> there
> is more detail; some found.
>
> I suspect that I may have two problems: some issue with the right angle
> drive and some issue with the speedometer head.  I am inclined to go after
> the right angle drive first.
>
> Can someone point me to guidance on gaining access to the right angle 
> drive?
> Seems I have to go after it from the cockpit after removal of the
> driveshaft/transmission tunnel.
>
>
>
> Thanks, Mike
>
>
>
> Michael Garvey
>
> 1967 BJ8/38046
>
> Swampscott, MA
> _______________________________________________
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
>
> [email-masked]
> http://autox.team.net/mailman/listinfo/healeys
>
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/healeys/[email-masked] 
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: john spaur <[email-masked]>
Date: Fri, 28 Dec 2012 12:06:51 -0800

Mike,

The angle drive is the same as the one on a BT7 it is repairable. You 
need to remove the disk plate and use a short section of speedo 
cable. If you don't have one that you can cut up I saw some after 
market cables in a national chain auto parts store the other day that 
looked like they would work. You may need to file one end of the 
repair cable to make it square. It's not very difficult.

John Spaur
'62 BT7

[email-masked]