Subject: Re: [Healeys] Problems with SC Parts

From: Bob Haskell <[email-masked]>
Date: Fri, 11 Jan 2013 06:35:07 -0500

I had the same problem a couple of years ago.  Never knew when/if parts 
would ship.  Ordered a set of push rods for a Mini - received 4 OEM 
style and 4 tubular. Took a couple of phone calls to straighten that 
out.  So, I've not dealt with them since.

Bob Haskell
AHCA 3000 Mk I registrar
http://www.ciahc.org/registry_3000mk1.php

On 01/11/2013 05:01 AM, Derek Job wrote:
> Anybody else having problems with SC? They appear to be totally
> re-organising their distribution system, I ordered 3 Webers that were 'in
> stock' about 2 weeks ago and they still have not been dispatched from a
> warehouse in Germany! I can't seem to get any sensible answers or any
> action., other than 'they will be dispatched the middle of next week,'
> ...which was the same answer as last week.
>
> I don't plan on using them again.
>
> Derek
> _______________________________________________
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
>
> [email-masked]
> http://autox.team.net/mailman/listinfo/healeys
>
> Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: "Simon Lachlan" <[email-masked]>
Date: Fri, 11 Jan 2013 13:35:36 -0000

Yes, problems. Ongoing.
No, won't use them again.
Wouldn't advise others to use them. 
Were OK for a while after the Limora takeover, then right downhill.
Simon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Derek Job
Sent: 11 January 2013 10:01
To: Forum
Subject: [Healeys] Problems with SC Parts

Derek
$12.75

[email-masked]

http://autox.team.net/mailman/options/healeys/[email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]

---

From: Derek Job <[email-masked]>
Date: Fri, 11 Jan 2013 13:41:04 +0000

Thanks Simon.

I only used them because of the 20% discount. Big mistake. The only other
time was when I bought 6 small bolts all of the same type. When they
arrived there were three different sizes included in the 6!

Does anyone know if the parent company Limora is still in good shape?

Has anyone actually received any kindof large order from them recently?

If they are really are as bad as it seems the Club must stop taking their
ads.

Derek

On Fri, Jan 11, 2013 at 1:35 PM, Simon Lachlan <[email-masked]
> wrote:

> Support Team.Net http://www.team.net/donate.html Suggested annual donation
> $12.75
> Unsubscribe/Manage:

[email-masked]

---

From: "John Sims" <[email-masked]>
Date: Fri, 11 Jan 2013 09:15:44 -0500

I have added a caveat on their listing on my site. Limora also.

John Sims, BN6
Aberdeen, NJ

www.healey6.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Derek Job
Sent: Friday, January 11, 2013 8:41 AM
To: Simon Lachlan
Cc: Forum
Subject: Re: [Healeys] Problems with SC Parts

Thanks Simon.

I only used them because of the 20% discount. Big mistake. The only other
time was when I bought 6 small bolts all of the same type. When they arrived
there were three different sizes included in the 6!

Derek

[email-masked]

---

From: [email-masked]
Date: Sat, 12 Jan 2013 09:34:48 -0500 (EST)

Probably like most of you, I receive frequent "specials" notifications from SC
Parts. Often the same notification twice the same day. They do not provide any
way to opt out of the mailings & I have emailed them 5 or 6 times requesting
to be removed from their mass mailings but they just keep coming. I am about
to add them to my spam blocker list.
Gary Hodson
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]

---

From: Austin Healey <[email-masked]>
Date: Sat, 12 Jan 2013 17:08:04 +0100

"I am about to add them to my spam blocker list."

I already done it. I was also unfortunate to pay for something and got
another item. They told me it is a "direct replacement". Oh yes: 1.5 degree
negative arm "replaces" the 2.5 degree arm. Ermm.... no.

Gergo

2013/1/12 <[email-masked]>

> http://autox.team.net/mailman/options/healeys/[email-masked]

[email-masked]