Subject: [Healeys] BJ8 brake caliper question

From: Tom Felts <[email-masked]>
Date: Wed, 17 Jul 2013 18:04:52 -0400

Had my right caliper pistons seize today causing one HOT set of brake pads and roter.  Pulled them and removed pistons----very dirty as I suspected.  The piston cavities need a good cleaning.

What do you use to make sure this surface is clean and shiny before you replace the new pistons?  Don't want to sand blast---tried a real fine steel wool, but can't get it as clean as I want.

Thanks
tom
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Tom Felts <[email-masked]>
Date: Wed, 17 Jul 2013 19:25:24 -0400

Thanks Bob---already pulled and regreased the bearings.

tom

---- Bob Haskell <[email-masked]> wrote: 

=============
Tom,

As the seal sits in the groove in the caliper bore, the seal "moves" 
against the piston not the bore.  So, the caliber bores don't have to 
in pristine shape.

Would suggest that you pull the hub and make sure that the wheel 
bearings didn't get too hot causing the grease to melt away.

Cheers,

Bob Haskell
AHCA 3000 Mk I registrar
http://www.ciahc.org/registry_3000mk1.php

On 07/17/2013 06:04 PM, Tom Felts wrote:
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Forums: http://www.team.net/forums
>
> [email-masked]
> Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

[email-masked]

---

From: Tom Felts <[email-masked]>
Date: Thu, 18 Jul 2013 9:50:38 -0400

Thanks Peter----it was definitely the pistons-------corrosion problem----had to blow one out this AM with a high pressure air hose.  Pretty messy in there?  Still waiting for my O/N parts and then remount and hopefully have it ready for the PVGP this weekend.

Tom
---- Peter Caldwell <[email-masked]> wrote: 

=============
Tom,  Replace the hoses as they could be the actual cause, unless you 
are certain they are new.
         Peter C
=
At 05:04 PM 7/17/2013, Tom Felts wrote:
>Had my right caliper pistons seize today causing one HOT set of 
>brake pads and roter.  Pulled them and removed pistons----very dirty 
>as I suspected.  The piston cavities need a good cleaning.
>
>What do you use to make sure this surface is clean and shiny before 
>you replace the new pistons?  Don't want to sand blast---tried a 
>real fine steel wool, but can't get it as clean as I want.
>
>Thanks
>tom

[email-masked]

---

From: Tom Felts <[email-masked]>
Date: Thu, 18 Jul 2013 15:08:11 -0400

Parts came in on time and brake system is back together--all are working beautifulle.  Good to have safe reliable brakes again.

There is a lesson here though--------you simply can't just let the brake sustem go on and on and on----you need to have the system services on some frequency.  This I will do in the future.

Thanks to all for all your helpful comments.

tom

---- Tom Felts <[email-masked]> wrote: 

=============

Tom

=============

[email-masked]

[email-masked]

---

From: Tom Felts <[email-masked]>
Date: Thu, 18 Jul 2013 15:10:32 -0400

Good advice Ed-----unfortunately I didn't think to order new ones and wanted to get the car ready for the PVGP this weekend.  so----hoses will definitely be on a not-too-distant future schedule.

---- "\" Just Brits \" Shop" <[email-masked]> wrote: 

=============
<< On 7/18/2013 8:45 AM, Peter Caldwell wrote:

Tom,  Replace the hoses as they could be the actual cause, unless you 
are certain they are new. >>

1st time I've "dis-agreed" with PPP  ! ! !  LOL

Tom, for my $ .05 change the hoses anyway.  CHEAP 'insurance' <G>.  
Even brand new ones 'can'
delaminate and give you all kinds of grief ! !

Safety is my mantra ! ! <G>
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]

---

From: [email-masked]
Date: Thu, 18 Jul 2013 20:53:38 +0000 (UTC)

At least every 20 years!

----- Original Message -----
From: "Tom Felts" <[email-masked]>
To: "Peter Caldwell" <[email-masked]>, "Tom Felts"
<[email-masked]>, [email-masked]
Sent: Thursday, July 18, 2013 3:08:11 PM
Subject: Re: [Healeys] BJ8 brake caliper question

Parts came in on time and brake system is back together--all are working
beautifulle. B Good to have safe reliable brakes again.

There is a lesson here though--------you simply can't just let the brake
sustem go on and on and on----you need to have the system services on some
frequency. B This I will do in the future.

tom

=============
Thanks Peter----it was definitely the pistons-------corrosion problem----had
to blow one out this AM with a high pressure air hose. B Pretty messy in
there? B Still waiting for my O/N parts and then remount and hopefully have it
ready for the PVGP this weekend.

Tom

=============
Tom, B Replace the hoses as they could be the actual cause, unless you
are certain they are new.
B B  B  B  B  Peter C
=
At 05:04 PM 7/17/2013, Tom Felts wrote:
>brake pads and roter. B Pulled them and removed pistons----very dirty
>as I suspected. B The piston cavities need a good cleaning.
>
>you replace the new pistons? B Don't want to sand blast---tried a

[email-masked]

http://autox.team.net/mailman/options/healeys/[email-masked]
Archive: http://www.team.net/archive

[email-masked]

http://autox.team.net/mailman/options/healeys/[email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]

---

From: "\" Just Brits \" Shop" <[email-masked]>
Date: Thu, 18 Jul 2013 16:05:52 -0500

<< On 7/18/2013 3:53 PM, [email-masked] wrote:

At least every 20 years!  >>

A fool and his life are soon parted (hopefully only the fool involved).

Ed

[email-masked]

---

From: Tom Felts <[email-masked]>
Date: Thu, 18 Jul 2013 20:12:39 -0400

Great--that means I'll never have to do it again:):)

---- [email-masked] wrote:

=============
At least every 20 years!

----- Original Message -----
From: "Tom Felts" <[email-masked]>
To: "Peter Caldwell" <[email-masked]>, "Tom Felts"

tom

=============

Tom

=============

[email-masked]

[email-masked]

[email-masked]