Subject: [Healeys] Distributor lubrication

From: john spaur <[email-masked]>
Date: Wed, 07 Aug 2013 21:41:50 -0700

Is there supposed to be a little felt plug under the rotor that is 
oiled? Neither the parts manual or the workshop manual shows one but 
for some reason I think there is supposed to be one.

TIA,
John Spaur
'62 BT7
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: <[email-masked]>
Date: Thu, 8 Aug 2013 13:43:48 +0200

On some distributors there is a felt pad, on others there is not. You can always retro-fit one, either made up yourself or from any specialist.
Either way you have to administer a few drops of oil once in a while. Also do not forget to lubricate the centrifugal advance weights below the base plate. A squirt of penetrating oil will usually be OK, but better is to remove the base plate and apply a few drops of engine oil to the mechanism.

Kees Oudesluijs
NL

-

[email-masked]