Subject: [Healeys] name engraved behind bumperhorn

From: "Niels Bengaard" <[email-masked]>
Date: Wed, 21 Aug 2013 20:10:22 +0200

I have a 1966 BJ8 imported to Denmark from San Francisco.
On the back of both front bumper horns the name Savelson is engraved.
Why would anyone do that, could it be the name of a previous owner or?
http://healey.850r.dk/pictures/savelson.jpg

---
Niels Bengaard
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Bob Spidell <[email-masked]>
Date: Wed, 21 Aug 2013 18:34:50 +0000 (UTC)

Would guess a previous owner engraved his/her name for identification purposes after theft (i.e. VIN tags removed). 

Google 'Savelson' ... there are a few noteworthy namesakes. 

Bob 

-------------------------------- 
Bob Spidell - San Jose, CA 

----- Original Message -----
From: "Niels Bengaard" <[email-masked]> 
To: "healeylist" <[email-masked]> 
Sent: Wednesday, August 21, 2013 11:10:22 AM 
Subject: [Healeys] name engraved behind bumperhorn 

--- 
Niels Bengaard 

[email-masked]

---

From: [email-masked]
Date: Wed, 21 Aug 2013 16:09:06 -0400 (EDT)

Looks like a rechromed part.  Suggest it was a way to ID the parts during the
process.
Aloha
Perry

-----Original Message-----
From: Niels Bengaard [email-masked]

I have a 1966 BJ8 imported to Denmark from San Francisco.
n the back of both front bumper horns the name Savelson is engraved.
hy would anyone do that, could it be the name of a previous owner or?
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]

---

From: "\" Just Brits \" Shop" <[email-masked]>
Date: Wed, 21 Aug 2013 15:13:56 -0500

My first thought was ID for chromer ? ? ?
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]