Subject: [Healeys] Webers, dellortos

From: "Simon Lachlan" <[email-masked]>
Date: Fri, 13 Dec 2013 20:28:04 -0000

I am thinking about putting 3 webers or dellortos on my 3000. 

It has a big bore bunch of bananas exhaust and a Denis Welch fast road cam
so it's half way there, if you see what I mean.

Now, wise gurus will say "if it ain't  broke, don't fix it" and one already
has! But these things have a dreadful fascination....a bit like Everest!

So, in any particular order, what does your experience say?.....

Dellortos or Webers? 

Which size/type? 45DCOE seems to be the Webers that most people mention or
sell. (Are they really made our of platinum?)

Are there any 6 cyl cars out there whose inlet manifolds fit ours? ie the
Datsun 250Z or the (old) BMW 3.0? Certainly, the Datsun people seem to have
plenty of bits and pieces; if only they'd fit.

What other tips?...

A bit late, but it's amazing how responsive Father Christmas can be.....

Simon
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Jackson Krall <[email-masked]>
Date: Sat, 14 Dec 2013 12:07:53 -0800 (PST)

------------------------------
On Sat, Dec 14, 2013 1:32 PM EST Jackson Krall wrote:

>
>
>Despite their reputation for high fuel consumption and not necessary for normal daily driving, I've wondered if it is possible to use the triple weber/dellortos tuned with economy in mind rather than ultimate performance and in conjunction with appropriate cam, headers/exhaust and achieve a bit better performance and better mpg? Anyone had any success in this direction?
>Best
>JK
>
>
>------------------------------
>On Sat, Dec 14, 2013 5:10 AM EST Derek Job wrote:
>
>>Simon
>>
>>The truth is that you really only need Webers for racing or competitionbut so
>>whatthey look fantasticso why not.
>>
>>I'm sure Kees will tell you to get Dellortos and he may be right, but Webers
>>are what everybody goes for.
>>
>>The most common set up is using 45 DCOE's with 36mm chokes. Mine use the
>>following
>>
>>Choke 36mm
>>
>>Aux venturi  4.5
>>
>>Main jet 145
>>
>>air corrector 155
>>
>>emmulsion tubes f16
>>
>>Idle jet 55 f6
>>
>>needle valve 200
>>
>>pump jet  45
>>
>>pump spill 40
>>
>>
>>Most of those came standard with the carbs out of the box, although a couple
>>of items were changed during the rolling road set up, the idle jet for one.
>>Setting up on a rolling road is essential but once they are properly set up,
>>you forget them.
>>If they are spitting they are not correctly set. (They might spit a bit on
>>start up when cold)
>>
>>You will also need to  budget for body work modifications. You have to cut
>>away the diagonal side brace, contrary to popular myth you do not need to cut
>>out a piece of the shroud to change jets etc, although it does improve access
>>to the stacks and whatever filters you put on.
>>
>>You will have to decide on a set of intake manifolds. You can get them from
>>the usual suspects. Obviously Welch ones are popular and claim to be virtually
>>identical to the ones used on the last works rally cars, although slightly
>>shorter so they don't need to have support towers. AH Spares might be worth a
>>look as they have been developing their performance parts in conjunction with
>>Anders Schildt. Or rather its Anders Schildt who has been developing them. The
>>longer intake manifolds on the works cars were probably the reason for the
>>shroud cut out, but as mentioned, this is not necessary with most of the
>>modern versions.
>>
>>If you are determined to blow all your christmas money you should consider
>>switching to a cable throttle which is a big improvement. Beware though its a
>>slippery slope!!!  next come the forged pistons, aluminium head, aluminium
>>back plate, roller rockers, lightweight fly wheel and alumium pulleyetc..
>>
>>Actually the DWR deep V pulley is a nice upgrade and not that costly.
>>
>>Good luck
>>
>>Derek
>>
>>
>>
>>
>>
>>On 13 Dec 2013, at 20:28, Simon Lachlan <[email-masked]> wrote:
>>
>> ______________________________________________

[email-masked]

---

From: Jackson Krall <[email-masked]>
Date: Sat, 14 Dec 2013 16:13:42 -0800 (PST)

Yes Eric, your use of 40 dcoe's is more to the point of my question.
Josef, I understand your point and I'm sure we all love SU's but my question pertains to the use of Weber/Dellorto sidedraft twinchoke carbs and whether their seemingly superior design for use on the series of 3 twinports of our Westlake designed post Longbridge C series cylnder heads would provide better economy and performance when tuned for road use as opposed to splitting the flow of 2 or 3 single choke SU carbs. Just looking for facts, no need to cloud the atmosphere with nonsense.
Thanks
Best
JK
NYC

------------------------------
On Sat, Dec 14, 2013 4:26 PM EST Wilko2 wrote:

>Ah yes, the illusive Weber HS4.
>
>I have a set of three of the HD6 or even three HD8 that I may run on this:
>
>ewilkins.com/wilko/healeys/engine_hd8.jpg
>
>I also will try the 40DCOEs
>
>On Dec 14, 2013, at 12:57 PM, [email-masked] wrote:
>
>> Oh yes, this setup is called the triple HS4. It looks close to a Stromberg,
>SU setup, but don`t worry. Its the real Webers. Those who don`t believe, you
>need the buy the Weber labels to fit on them.
>>
>> Josef Eckert
>> Konigswinter/Germany
>>
>> PS: I like these extremely rare trouble free premium Webers called SUs.
>>
>> -----Original-Nachricht-----
>> Betreff: Re: [Healeys] Webers, dellortos
>> Datum: Sat, 14 Dec 2013 21:07:53 +0100
>> Von: Jackson Krall <[email-masked]>
>> An: [email-masked]
>>
>> Despite their reputation for high fuel consumption and not necessary for
>normal daily driving, I've wondered if it is possible to use the triple
>weber/dellortos tuned with economy in mind rather than ultimate performance
>and in conjunction with appropriate cam, headers/exhaust and achieve a bit
>better performance and better mpg? Anyone had any success in this direction?
>> Best
     JK

[email-masked]