Subject: Re: [Healeys] FW: Voltage Regulator for a BN7

From: "Thomas Willig" <[email-masked]>
Date: Tue, 8 Jul 2014 10:03:12 +0200

I had regulator problems on my BN2 for nearly one year. My findings / opinions
are now:

-Do not buy a new regulator -The quality is catastrophic! I went through three
of them and not one of them worked for a longer period.

-A good thing is to try and get a NOS Lucas RB106 - the ones that were
produced in Merry Old England.

-I had an old RB106 convertet to solid state technologie. Very good result,
reliable and the charging starts already at 800 rpm. The times of a dimly
glowing charging lamp up to 1200 rpm are over!

Regards

Thomas Willig

-----Urspr|ngliche Nachricht-----
Von: Paul Blake [mailto:[email-masked]]
Gesendet: Dienstag, 8. Juli 2014 03:14
An: [email-masked]
Betreff: [Healeys] FW: Voltage Regulator for a BN7

Ron

In my view an original Lucas regulator is a better bet than a solid state job.
Find an old school auto electrician (they are around and love working on old
stuff) and get them to refurbish your Lucas regulator and set it up correctly.
They are tough units and will give good service for years and years. If they
do play up on the road you can at least adjust them to get you home.  The
important thing is to buy the right one.  They all have the same model number
(RB106/2) but the part number (usually stamped on the
side) tells you the amp rating. Healeys must have a 30 amp unit whereas most
MGs and Triumphs etc have smaller amp regulators.

Paul
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Magnus Karlsson <[email-masked]>
Date: Tue, 8 Jul 2014 11:12:52 +0200

Where did you have it converted?

Magnus Karlsson
BorC%s Motor Corporation AB
www.concourshealeys.com

> 8 jul 2014 kl. 10:03 skrev "Thomas Willig" <[email-masked]>:
>
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Forums: http://www.team.net/forums
>
> [email-masked]
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/healeys/[email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]

---

From: "Thomas Willig" <[email-masked]>
Date: Tue, 8 Jul 2014 11:38:38 +0200

There is a specialist in Germany whom I have used several times. See his homepage here:

http://www.edknet.de

If you need assistance -don't know if they talk English- drop me a note.

B 
Thomas Willig

-----UrsprC<ngliche Nachricht-----
Von: Magnus Karlsson [mailto:[email-masked]] 
Gesendet: Dienstag, 8. Juli 2014 11:13
An: Thomas Willig
Cc: <[email-masked]>
Betreff: Re: [Healeys] FW: Voltage Regulator for a BN7

Magnus Karlsson

> I had regulator problems on my BN2 for nearly one year. My findings / 
> opinions are now:
> 
> -Do not buy a new regulator -The quality is catastrophic! I went 
> through three of them and not one of them worked for a longer period.
> 
> -I had an old RB106 convertet to solid state technologie. Very good 
> result, reliable and the charging starts already at 800 rpm. The times 
> of a dimly glowing charging lamp up to 1200 rpm are over!
> 
> Regards
> 
> 
> Thomas Willig
> 
> 
> 
> They are tough units and will give good service for years and years. 
> If they do play up on the road you can at least adjust them to get you 
> home.  The important thing is to buy the right one.  They all have the 
> same model number
> side) tells you the amp rating. Healeys must have a 30 amp unit 
> whereas most MGs and Triumphs etc have smaller amp regulators.
> 
> Paul
> Support Team.Net http://www.team.net/donate.html Suggested annual 
> donation  $12.75

[email-masked]

---

From: "Thomas Willig" <[email-masked]>
Date: Tue, 8 Jul 2014 11:41:03 +0200

..pictures of converted Lucas units here:

http://www.edknet.de/archiv6.htm

(No financial interest...from my side, just a satified customer))

B 
Thomas Willig

-----UrsprC<ngliche Nachricht-----
Von: Magnus Karlsson [mailto:[email-masked]] 
Gesendet: Dienstag, 8. Juli 2014 11:13
An: Thomas Willig
Cc: <[email-masked]>
Betreff: Re: [Healeys] FW: Voltage Regulator for a BN7

Magnus Karlsson

[email-masked]

---

From: Bob Spidell <[email-masked]>
Date: Tue, 08 Jul 2014 17:19:03 -0700

Was doing some searching, and came across this:

http://www.dynamoregulatorconversions.com

Know nothing about them, but when I inquired, they responded quickly:

'Hello Bob, your C42 dynamo is rated at 25a. Currently our biggest regulator is 22a rated but we are working on a 28a 
version to replace it.

Keep watching the website for details.

It will be going into production soon.'

Interestingly, they claim with their conversion the red 'battery' light (on the tach) never comes on; implies the 
generator generates sufficient current even at low idle.

NFI, no experience, etc.

Bob

On 7/8/2014 2:41 AM, Thomas Willig wrote:
> *******************************************************************
> Bob Spidell           San Jose, CA            [email-masked]
>
> *******************************************************************

[email-masked]

---

From: Charlie Baldwin <[email-masked]>
Date: Tue, 08 Jul 2014 22:20:07 -0400

Bob,

Surely there is someone in the British car community in the USA that has 
the knowledge to do this conversion and make some money along the way.  
Bob Jeffers did a great job.  I have three or four five post regulators 
done by him and am quite satisfied.  Perhaps a lister in New Hampshire 
can find out who now has the technology. 
http://wilton-auto-electric-llc.wilton.nh.amfibi.com/us/c/2413997-wilton-auto-electric-llc

Or someone can figure out how to do it.

I emailed Andy Sifferman to try to find out if he has passed on the 
business to anyone, but heard nothing back from him.  Though maybe it 
was the wrong Andy.  Wilton AE's website is no longer up.

Charlie

On 7/8/2014 8:19 PM, Bob Spidell wrote:
> 'Hello Bob, your C42 dynamo is rated at 25a. Currently our biggest 
> regulator is 22a rated but we are working on a 28a version to replace it.
>
> Interestingly, they claim with their conversion the red 'battery' 
> light (on the tach) never comes on; implies the generator generates 
> sufficient current even at low idle.
>
> NFI, no experience, etc.
>
> Bob

[email-masked]

---

From: Bob Spidell <[email-masked]>
Date: Tue, 08 Jul 2014 20:46:17 -0700

Charlie,

If you find someone, please let us all know.  I've decided a refresh of my charging system is due.

Bob

On 7/8/2014 7:20 PM, Charlie Baldwin wrote:
> Bob,
>
> Surely there is someone in the British car community in the USA that has the knowledge to do this conversion and make 
> some money along the way.  Bob Jeffers did a great job.  I have three or four five post regulators done by him and am 
> quite satisfied.  Perhaps a lister in New Hampshire can find out who now has the technology. 
> I emailed Andy Sifferman to try to find out if he has passed on the business to anyone, but heard nothing back from 
> him.  Though maybe it was the wrong Andy.  Wilton AE's website is no longer up.
>
> Charlie
>
>
>

-- 

[email-masked]

---

From: Charlie Baldwin <[email-masked]>
Date: Wed, 09 Jul 2014 07:10:39 -0400

Ron,

I was thinking the same thing.  I'll reach out to the members of some of 
the local clubs here in PA to see if there are any electronics experts 
who may want to take it on.

Charlie

On 7/9/2014 12:09 AM, Ron Fine wrote:
> Perhaps one or your regulators could be reverse engineered to see what 
> components were use and copied?  I don't really now how difficult such 
> a task would be but maybe someone on this list has the experience or 
> knowledge.  I doubt that the components would be so difficult to 
> source and put together.
>
> Ron
>
> -----Original Message----- From: Charlie Baldwin
> Sent: Tuesday, July 08, 2014 7:20 PM
> To: [email-masked]
> Subject: Re: [Healeys] FW: Voltage Regulator for a BN7
>
> Bob,
>
> http://autox.team.net/mailman/options/healeys/[email-masked]

[email-masked]

---

From: Alan Bromfield <[email-masked]>
Date: Wed, 9 Jul 2014 13:46:32 +0100

Hi Charlie.
The reverse engineering has been done and published. Check this out:
*http://tinyurl.com/ps93dom <http://tinyurl.com/ps93dom>*

Now all we need is an 'Electrickery Wizard' that could take it on. I'm a
customer for at least two of them and maybe more among fellow club members
over here.

On 9 July 2014 12:10, Charlie Baldwin <[email-masked]> wrote:

> the local clubs here in PA to see if there are any electronics experts who
> may want to take it on.
>
> Charlie
>
>
>> components were use and copied?  I don't really now how difficult such a
>> task would be but maybe someone on this list has the experience or
>> knowledge.  I doubt that the components would be so difficult to source and
>> put together.
>>
>> Ron
>>
>>   _________________________________________
>> (______________ Alan Bromfield_______________)
>>         (_______\____1957-BN4____/________)
>>                 (_____bluehealey.com_____)

[email-masked]

---

From: "Alex" <[email-masked]>
Date: Wed, 9 Jul 2014 11:24:09 -0400 a=fDrs+h473TBVBgRLKGUt+A==:117 a=fDrs+h473TBVBgRLKGUt+A==:17 a=ayC55rCoAAAA:8 a=zTVDa7HKqxcA:10 a=8nJEP1OIZ-IA:10 a=doupyKFmAAAA:8 a=8A7brI4kjU8C6ETGAX3PRdgeao0=:19 a=7kyj-MwJZSj2Nl7xFwcA:9 a=wPNLvfGTeEIA:10

It is with some interest that I've been following this thread, as the folks
on the MG-T reflector have similar wishes.

Being an "electroniker" (for about 55 years; you can see some of my Web
projects here: http://home.roadrunner.com/~alexmm/  ) one of my MG friends
asked about an electronic control box (voltage regulator). He knew the folks
in New Hampshire that knew the Jeffers family.  With his connection I
visited an automobile restoration shop in NH and they kindly gave me a
Jeffers voltage regulator for an MG-T car that is supposedly defunct, but
intact.

Inspecting it, I was not impressed. For starters, the Jeffers Wilton box
uses edge-wipe sockets to hold the two integrated circuits (ICs) in the
regulator. Edge-wipe IC sockets are low reliability interconnects. In my
radio service business, and in my hobby work, I never use them. I have seen
them exhibit failures due to moisture and oxidation, even in benign
non-automotive applications.

For my money, I only use screw-machined IC sockets. These make what is
called a gas-tight seal between the lead frames (pins) of the IC package,
and the socket. Screw-machined sockets are the only types I would use to
hold ICs in a circuit board that would be subject to shock, vibration, and
extremes of temperature, which is what you have under the bonnet of our
cars. They are more expensive than the cheap edge-wipe sockets, but they are
utterly reliable in this application where there is a separable
interconnect.

The Jeffers voltage regulator also uses a pair of 8-pin "miniDIP" ICs that
are unmarked. He apparently ground off the nomenclature in order to preserve
his proprietary design. I suspect they are op-amps or comparators, and I
have thought about reverse engineering the board to generate a schematic,
but haven't been motivated to do that yet.

The shop I received the regulator from did contact the Jeffers family about
a month ago to determine if his notes and/or components might be available,
but I was told the family is still in mourning and didn't wish to pursue
this at this time. I may try again in a few months.

In the meantime, as you can see, there are outfits that make these voltage
regulators, and there is also a goodly amount of info on the Web about how
to roll your own. Some of the designs avoid using ICs, and use only discrete
semiconductors. These designs seem simpler to me.

In addition to the reference cited in this reflector, there is info on the
Web about how to use a 30019 Bosch regulator as an RB106 substitute.

== Alex in Maine
     "The Blue Mainie," 1960 Austin Healey 3000 BT7
     "Conkling," 1946 M.G. TC #1321
     Former owner 1957 A-H 100-6, 1967 A-H BJ8,
     1965 MG Midget
     http://home.roadrunner.com/~alexmm
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]

---

From: I Erbs <[email-masked]>
Date: Wed, 9 Jul 2014 08:41:20 -0700

Might have a guy who could build these.
 Would like to get an idea of the demand and a supply of regulators to
upgrade. Contact me off list at [email-masked] if interested? Anyone who
has bought one, can you tell me how much you paid?

Ira Erbs
Portland, OR
   _______                                  _______
     (______ \____1960 BT7____/ _______)
         (_________________________)

On Wed, Jul 9, 2014 at 5:46 AM, Alan Bromfield <[email-masked]> wrote:

> http://autox.team.net/mailman/options/healeys/[email-masked]

[email-masked]

---

From: Bob Spidell <[email-masked]>
Date: Wed, 9 Jul 2014 15:54:06 +0000 (UTC)

I'm interested (in fact, I'll do this if the right product is available). Note for BJ8s--and maybe BJ7s--the regulator is an RB340 rated at, I think, 30 amps (though the dynamo is apparently only good for 25A). 

Bob 

----- Original Message -----

From: "I Erbs" <[email-masked]> 
To: "Alan Bromfield" <[email-masked]> 
Cc: "healeys" <[email-masked]> 
Sent: Wednesday, July 9, 2014 8:41:20 AM 
Subject: Re: [Healeys] FW: Voltage Regulator for a BN7 

Ira Erbs 
Portland, OR 
_______ _______ 

[email-masked]

---

From: Charlie Baldwin <[email-masked]>
Date: Wed, 09 Jul 2014 20:24:23 -0400

Alan,
I think that you posted that before.  It's way over my head, but just 
looking at it doesn't appear to be the same as Jeffers did it. I don't 
know if that is good or bad.  Alex in Maine feels that he can do better 
than Bob's design, which I welcome anyone to do. There are a lot of cars 
that use the 5 post regulator, and also other regulators can also be 
converted.  I know that Mr. Jeffers did others and would also do 
variations.  He did two for me to use a Bosch generator for a Volvo 
engine swap in an MG TD.  I have a friend with a Morris Minor who got a 
6 volt version from him.
Charlie

On 7/9/2014 8:46 AM, Alan Bromfield wrote:
> *http://tinyurl.com/ps93dom*
> Now all we need is an 'Electrickery Wizard' that could take it on. I'm 
> a customer for at least two of them and maybe more among fellow club 
> members over here.
>
> On 9 July 2014 12:10, Charlie Baldwin <[email-masked] 
>
>     Ron,
>
>     I was thinking the same thing.  I'll reach out to the members of
>     some of the local clubs here in PA to see if there are any
>     electronics experts who may want to take it on.
>
>     Charlie
>
>
>         Perhaps one or your regulators could be reverse engineered to
>         see what components were use and copied?  I don't really now
>         how difficult such a task would be but maybe someone on this
>         list has the experience or knowledge.  I doubt that the
>         components would be so difficult to source and put together.
>
>         Ron
>

[email-masked]