Subject: Re: [Healeys] Block Drain

From: "john" <[email-masked]>
Date: Wed, 6 Aug 2014 16:40:00 -0700

Remove the entire drain. It is most likely plugged anyway and you will need
to rod it out with a wire to get it to drain. If you try and drain it by
turning the handle it will probably break and when you close it, it will
probably leak until crud plugs it up again.

John Spaur
'62 BT7
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Bob Haskell <[email-masked]>
Date: Wed, 06 Aug 2014 19:42:52 -0400

Price,

The threaded section in the block is quite thick.  I don't think you 
have to worry about it breaking off.  Probably a Whitworth sized nut.
There should be a fiber washer between the block and the petcock.

Cheers,

Bob Haskell
AHCA 3000 Mk I registrar
http://www.ciahc.org/registry_3000mk1.php

On 08/06/2014 07:24 PM, R. Price Lindsay wrote:
> I am in the process of flushing out the cooling system of my BJ8.  It has been
> a few years since I did this and when I did it last, I did not open the block
> drain.  I'm not sure it has ever been opened but its time has come.  I presume
> the unit is brass, but not sure.  My concern is if I put too much pressure on
> it with a wrench (I want to take it off rather than try and turn the shuttle
> cock) it will break or the threads will strip creating another set of "real"
> issues.
>
> Any words of caution, processes to follow or other encouragement??
>
> Thank you, as always, in advance.
>
> Price Lindsay
> 67 BJ8
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Forums: http://www.team.net/forums
>
> [email-masked]
> Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

[email-masked]

---

From: WILLIAM B LAWRENCE <[email-masked]>
Date: Thu, 7 Aug 2014 00:56:30 +0000

The brass doesn't rust like iron or corrode electrolytically like aluminum
(ium?) so it's not likely to be stuck in its thread. It will probably just
screw out.

Bill Lawrence

> Date: Wed, 6 Aug 2014 19:42:52 -0400
> From: [email-masked]
> To: [email-masked]; [email-masked]
> Subject: Re: [Healeys] Block Drain
>
> Price,
>
> > Unsubscribe/Manage:
http://autox.team.net/mailman/options/healeys/[email-masked]
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/healeys/[email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]