Subject: Re: [Healeys] holidays...

From: I Erbs <[email-masked]>
Date: Mon, 13 Oct 2014 08:17:37 -0700

You mean Native American subjugation Day does not have the same ring?

Ira Erbs
Portland, OR
   _______                                  _______
     (______ \____1960 BT7____/ _______)
         (_________________________)

On Mon, Oct 13, 2014 at 8:12 AM, David Porter <[email-masked]>
wrote:

> And today is the traditional American Columbus Day.. however, that has
> been deemed too politically incorrect for those who, for reasons
> unbeknownst to me, have the power to make such asinine changes to
> tradition...
> dave
> --
> Dave Porter Porter Custom Bicycles 2909 Arno St. NE Albuquerque, NM 87107
> 505-352-1378 Go HERE: my world www.porterbikes.com/
> _______________________________________________
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
>
> [email-masked]
> http://autox.team.net/mailman/listinfo/healeys
>
> Unsubscribe/Manage: http://autox.team.net/mailman/
> options/healeys/[email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Bob Spidell <[email-masked]>
Date: Mon, 13 Oct 2014 15:19:12 +0000 (UTC)

re: ".. for reasons unbeknownst to me .." 

Here's a few: 

http://www.huffingtonpost.com/eric-kasum/columbus-day-a-bad-idea_b_742708.html 

----- Original Message -----

From: "David Porter" <[email-masked]> 
To: "healeys" <[email-masked]> 
Sent: Monday, October 13, 2014 8:12:52 AM 
Subject: [Healeys] holidays... 

And today is the traditional American Columbus Day.. however, that has 
been deemed too politically incorrect for those who, for reasons 
unbeknownst to me, have the power to make such asinine changes to 
tradition... 
dave 
-- 
Dave Porter Porter Custom Bicycles 2909 Arno St. NE Albuquerque, NM 
87107 505-352-1378 Go HERE: my world www.porterbikes.com/ 
_______________________________________________ 
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]

---

From: Ron Mitchell <[email-masked]>
Date: Mon, 13 Oct 2014 10:56:31 -0700

I thought we agreed to keep political opinions off this Forum.  

Ron Mitchell

On Monday, October 13, 2014 11:12 AM, David Porter <[email-masked]> wrote:

[email-masked]

[email-masked]