Subject: Re: [Healeys] oil filters

From: Bob Spidell <[email-masked]>
Date: Mon, 10 Nov 2014 04:51:28 -0800

I use Wix# 51516.  It has a silicone 'check valve;' I know because I've cut them open.  It's a good quality filter all 
around, at a reasonable price.

Bob

On 11/10/2014 2:05 AM, Dennis Gavin wrote:
> Some time ago I read an article that warned when using a spin on oil filter,
> with the spin on adapter, make sure the filter has the back flow valve.
> Apparently this stops the oil in the filter from draining into the sump. It
> makes sense to me but not sure what type (mfg) or model designation would be
> appropriate for my 63 BJ7. Hoping this fantastic list can help. Thanking you
> all in advance.
>
> Dennis Gavin
> Hopedale, MA
> 63 BJ7
> 63 E Type
> 48 Willys Jeepster
> _______________________________________________
>
>
>

-- 
*******************************************************************
Bob Spidell           San Jose, CA            [email-masked]

*******************************************************************
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Michael Oritt <[email-masked]>
Date: Mon, 10 Nov 2014 08:06:20 -0500

I use a K & N 2009.

Best--Michael Oritt

On Mon, Nov 10, 2014 at 5:05 AM, Dennis Gavin <[email-masked]>
wrote:

> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Forums: http://www.team.net/forums
>
> [email-masked]
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/healeys/[email-masked]

[email-masked]

---

From: JOHN BAHE SR <[email-masked]>
Date: Mon, 10 Nov 2014 08:36:26 -0500

I have had good luck with the Napa Goild filter number 1516; manufactured
by Wix and, has an anti drain valve and is available at any Napa store.
They have less expensive filters that will also fit this application if
price is a consideration.

John

On Mon, Nov 10, 2014 at 8:06 AM, Michael Oritt <[email-masked]>
wrote:

> http://autox.team.net/mailman/options/healeys/[email-masked]
>
>

-- 
John A Bahe Sr.
Cell:  (502) 599-2696
[email-masked]

[email-masked]