Subject: [Healeys] Stuck needle valve

From: Frank Magnusson <[email-masked]>
Date: Fri, 8 May 2015 19:51:44 -0500

Just taking my BJ8 out of storage and it looks like I have a stuck needle valve in one of the carbs.  Fuel pump continues to run somewhat and fuel coming out of one of the overflow pipes.  Not pouring out, but not just dripping either.

Anyone have any clever suggetions for unsticking it without pulling the float bowl lid off?  

Thanks,
Frank

Sent from my iPad
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Larry Wendland <[email-masked]>
Date: Sat, 9 May 2015 11:22:55 -0400

It could also be a sunken or partially sunken float.  If it is partially fuel logged, it might not have enough upward pressure to shut the float valve completely off.  Easy enough to detect a fuel logged float by lifting out the float and shaking it and there should be no liquid inside it. 

Larry
'67 BJ8

-----Original Message-----
From: Michael Oritt <[email-masked]>
To: Frank Magnusson <[email-masked]>
Cc: healeys <[email-masked]>
Sent: Sat, May 9, 2015 5:21 am
Subject: Re: [Healeys] Stuck needle valve

  
Frank--  

  
You've probably already spent more time thinking about a way around removing the lid than actually doing it, and in any case you'll want to see and know what is actually going on in the bowl as it could be a multitude of things ranging from debris, a worn pin, etc.  

  
Go have a look--Michael Oritt  

  
On Fri, May 8, 2015 at 8:51 PM, Frank Magnusson    <[email-masked]> wrote:   
   Just taking my BJ8 out of storage and it looks like I have a stuck needle valve in one of the carbs.  Fuel pump continues to run somewhat and fuel coming out of one of the overflow pipes.  Not pouring out, but not just dripping either.    

 Thanks,    
 Frank    
     
 Sent from my iPad    
 _______________________________________________    
 Support Team.Net     http://www.team.net/donate.html    
 Suggested annual donation  $12.75    
 Archive:     http://www.team.net/archive    
 Forums:     http://www.team.net/forums    
     
     [email-masked]    
     
 Unsubscribe/Manage:     http://autox.team.net/mailman/options/healeys/[email-masked]    

_______________________________________________Support Team.Nethttp://www.team.net/donate.htmlSuggested annual donation  $12.75Archive:http://www.team.net/archiveForums:http://www.team.net/[email-masked]://autox.team.net/mailman/listinfo/healeysUnsubscribe/Manage:http://autox.team.net/mailman/options/healeys/[email-masked]

_______________________________________________
Support Team.Net http://www.team.net/donate.html
Suggested annual donation  $12.75
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums

[email-masked]

Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

---

From: Frank Magnusson <[email-masked]>
Date: Sat, 9 May 2015 10:34:04 -0500

Good point!  I'll look for that also.

Thanks, Frank

Sent from my iPad

> On May 9, 2015, at 10:22 AM, Larry Wendland <[email-masked]> wrote:
> 

[email-masked]