Subject: Re: [Healeys] BJ8 Registrar

From: Bob Haskell <[email-masked]>
Date: Thu, 18 Aug 2016 05:15:51 -0400

Fred,

Steve Byers is the registrar and he participates in this list.  His 
email address is [email-masked].

Cheers,

Bob Haskell
AHCA 3000 MkI registrar
http://www.ciahc.org/registry_3000mk1.php

On 08/17/2016 11:26 PM, Fred Wescoe wrote:
> Who is the BJ8 registrar and what is the contact info.
>
> Thanks,
>
> Fred
>
>
> _______________________________________________
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
>
> [email-masked]
> http://autox.team.net/mailman/listinfo/healeys
>
> Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]
>
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Ken Fleming <[email-masked]>
Date: Thu, 18 Aug 2016 18:55:59 -0400

Steve Byers
[email-masked]
Ken
Sent from my iPhone

> On Aug 17, 2016, at 11:26 PM, Fred Wescoe <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]
> 

[email-masked]