Subject: [Healeys] Steering box

From: Mike <[email-masked]>
Date: Sat, 3 Sep 2016 12:30:29 -0700

I need to add lube to my BJ8 steering box.  In the archives, there were 
several references to Penrite.  Anyone have a comment? Where do I get 
it?  How easy is it to put in?  Do I have to drain the old stuff first 
(I hope not)?  Something else besides Penrite?  TIA.

-- 
Mike

MGTD (long gone)
BN1 (long gone)
BN2-100M (gone but in good hands)
BJ8
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Tom Felts <[email-masked]>
Date: Sun, 4 Sep 2016 7:57:15 -0400

I put Corn Head grease in mine--no leaks and steers like power steering almost.

---- John Vrugtman <[email-masked]> wrote: 

=============
forget penrite, impossible stuff.  Use something called "Multi-Luber" 
from the local John Deere dealer.  It's a relative of the famous Corn 
head grease.

John
On 9/3/2016 3:30 PM, Mike wrote:
> I need to add lube to my BJ8 steering box.  In the archives, there 
> were several references to Penrite.  Anyone have a comment? Where do I 
> get it?  How easy is it to put in?  Do I have to drain the old stuff 
> first (I hope not)?  Something else besides Penrite?  TIA.
>
>

[email-masked]

[email-masked]