Subject: Re: [Healeys] Fuses

From: Bob Spidell <[email-masked]>
Date: Sun, 17 Oct 2021 20:06:07 -0700

CRC makes a couple: 'Electronics Parts Cleaner,' and 'Electric Parts 
Cleaner.' The latter is suitable for applications like this, but use the 
former for electronic circuits and cleaning of other 'delicate' stuff. 
The electrical parts cleaner will remove most paints.

On 10/17/2021 5:23 PM, richard mayor via Healeys wrote:
> I don't usually believe in the "miracle in a can" foolishness, 
> .....BUT.... I am now a believer in the electric cleaner in a spray 
> can.  There are a couple of different brands.
>
> Over the last year and a half I brought back to life the electrical 
> systems of a '72 Mercedes and a '76 Alfa.  The cars had sat for 20 
> years and 16 years respectively. Both cars use the European style 
> ceramic fuses with aluminum exterior strips. I fiddled with ground 
> connections, fuses connections, etc, etc. with mixed results. There 
> was light corrosion everywhere. It was very frustrating and difficult 
> trying to clean so many connections by mechanical means.
>
> Then, on the recommendation of an Alfa guy I bought a can of the 
> 'lectric cleaner and gave it a try.  I was skeptical in the 
> beginning.  However, switches started switching,  Lights lit up. 
> Motors started moting.  Fuses started fusing.
>
> On some connectors I just backed off the screw enough to loosen and 
> wiggle the terminals and then sprayed away.  On many connectors I 
> didn't even do that.
>

_______________________________________________
Support Team.Net http://www.team.net/donate.html
Suggested annual donation  $12.75

Archive: http://www.team.net/pipermail/healeys http://autox.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

---

From: Alex <[email-masked]>
Date: Mon, 18 Oct 2021 08:21:21 -0400

In my bench work as a Certified Electronics Technician, I have been 
using, and recommend, spray-can DeOxit for years. Great stuff.

Alex in Maine

1960 BT7, The Blue Mainie

On 10/17/2021 11:06 PM, Bob Spidell wrote:
> Cleaner.' The latter is suitable for applications like this, but use 
> the former for electronic circuits and cleaning of other 'delicate' 
> stuff. The electrical parts cleaner will remove most paints.
>
>
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/healeys/[email-masked]
>

[email-masked]

---

From: "R. Lindsay" <[email-masked]>
Date: Wed, 20 Oct 2021 13:41:49 -0400

Thank you very much to those on this list that replied to my electrical issue!!

I found the problem (I hope) - a loose spade connector.  Everything seems to be working like it should - no hot wires. 

Again, thank for your help!  This list is amazing!!

Price Lindsay
67 BJ8

Sent from my iPhone

> On Oct 17, 2021, at 11:07 PM, Bob Spidell <[email-masked]> wrote:
> 
> CRC makes a couple: 'Electronics Parts Cleaner,' and 'Electric Parts Cleaner.' The latter is suitable for applications like this, but use the former for electronic circuits and cleaning of other 'delicate' stuff. The electrical parts cleaner will remove most paints.
> 
> 
>> I don't usually believe in the "miracle in a can" foolishness, .....BUT.... I am now a believer in the electric cleaner in a spray can.  There are a couple of different brands.
>> 
>> Over the last year and a half I brought back to life the electrical systems of a '72 Mercedes and a '76 Alfa.  The cars had sat for 20 years and 16 years respectively. Both cars use the European style ceramic fuses with aluminum exterior strips. I fiddled with ground connections, fuses connections, etc, etc. with mixed results. There was light corrosion everywhere. It was very frustrating and difficult trying to clean so many connections by mechanical means.
>> 
>> Then, on the recommendation of an Alfa guy I bought a can of the 'lectric cleaner and gave it a try.  I was skeptical in the beginning.  However, switches started switching,  Lights lit up. Motors started moting.  Fuses started fusing.
>> 
>> On some connectors I just backed off the screw enough to loosen and wiggle the terminals and then sprayed away.  On many connectors I didn't even do that.
>> 
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]
> 

[email-masked]

---

From: Bob Begani via Healeys <[email-masked]>
Date: Wed, 20 Oct 2021 14:53:08 -0400

Hi Price:

I had the same problem on the circuit to my electric fan and water pump which is only a few months old.  While the fuse was not hot, I changed it because it did not look as if it had a good connection to the holder on the fuse box.  New fuses a little longer that the older fuses and the ends just touch the holder.  Still no current flow. With the help of my friend who knows electric, we traced it to one loose wire to a spade and the other was wire to the alternator was just tired from overheating, so we installed new wire and connector and system worked.  I am hoping to remember all he showed me for the next time I have electrical problems.

Yes this Group is amazing.  

We should get together this winter.

Best regards,

Bob Begani

-----Original Message-----
From: Healeys <[email-masked]> On Behalf Of R. Lindsay
Sent: Wednesday, October 20, 2021 1:42 PM
To: Bob Spidell <[email-masked]>
Cc: [email-masked]
Subject: Re: [Healeys] Fuses

Price Lindsay
67 BJ8

Sent from my iPhone

> Support Team.Net http://www.team.net/donate.html Suggested annual 
> donation  $12.75
> 
> http://autox.team.net/mailman/options/healeys/[email-masked]
> 
_______________________________________________
Support Team.Net http://www.team.net/donate.html Suggested annual donation  $12.75

[email-masked]

Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

[email-masked]