Subject: [Healeys] Monty Auto Transport

From: Randy Hicks via Healeys <[email-masked]>
Date: Fri, 29 Sep 2023 10:06:04 -0400

Has anyone used Monty Auto Transport to ship a Car? Looking to ship non-Healey to AZ.

Appreciate any comments.

Randy
_______________________________________________

Archive: http://www.team.net/pipermail/healeys http://autox.team.net/archive/healeys

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Randy Hicks via Healeys <[email-masked]>
Date: Fri, 29 Sep 2023 12:20:02 -0400

Correction Montway Auto Transport

Randy

> On Sep 29, 2023, at 10:06 AM, Randy Hicks <[email-masked]> wrote:
> 

[email-masked]