Subject: [Mg-t] Supercharger?

From: Mark J Bradakis <[email-masked]>
Date: Tue, 17 Apr 2012 23:02:44 -0600 (MDT)

Anyone recognize this supercharger?  Who made it, any info?

http://bradakis.com/Images/super1.jpg
http://bradakis.com/Images/super2.jpg
http://bradakis.com/Images/super3.jpg

It was last used on an MG TF according to the fellow who last
owned it.

Thanks,

mjb.
______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $11.47
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/mg-t/[email-masked]

---

From: "lawrie" <[email-masked]>
Date: Wed, 18 Apr 2012 08:57:41 -0800

Not sure what this one is as I haven't ever seen one that looks like that. 

But, on the subject of superchargers for TCs, TDs, TFs or Y-types, I just happen to have two that need new homes. One is a Judson, one is a Shorrock. Both have the correct manifold for XPAG/XPEG engines, both have 1-1/2" SU carbs. And, both need to be overhauled and are not necessarily complete with all their brackets and fittings. I know for a fact that the Judson wasn't used after 1958 but have no history for the Shorrock. I'd like to get $1,000 for each of them; if you are interested, please contact me off-line.

Lawrie

>  -------Original Message-------
>  From: Mark J Bradakis <[email-masked]>
>  To: [email-masked]
>  Subject: [Mg-t] Supercharger?
>  Sent: 17 Apr '12 21:02
>  
>  Unsubscribe/Manage: http://autox.team.net/mailman/options/mg-t/[email-masked]

[email-masked]