Subject: Re: [Mg-t] front seal

From: [email-masked]
Date: Mon, 5 Aug 2013 05:27:43 -0400 (EDT)

Hello Mike,
Use a'88 volvo cam seal.
gates pn ks 13945.national # 1172, fel pro tcs45725. it fits better
than a moss seal, & has a double lip seal, not a single lip seal. No
machine work required
Len Fanelli

-----Original Message-----
From: Duvall Video Productions <[email-masked]>
To: mg-t <[email-masked]>
Sent: Sun, Aug 4, 2013 11:33 pm
Subject: [Mg-t] front seal

Does anyone have any experience with replacing the crank front rope seal
without removing the engine?  Is it possible?

( don't mention the crappy kits moss sells,  I used their parts and my T
leaks
worse than ever)
______________________________________________

[email-masked]
Archive: http://www.team.net/archive
______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: John Seim <[email-masked]>
Date: Mon, 5 Aug 2013 06:55:44 -0700

You have to remove the oil pan and front timing cover.
Chances are, the lip seal cut a groove into the cast iron front crank pulley.
You might want to place a Speedi-Sleeve onto the pulley shaft, for the rope
seal to seal against. CR99146. 1.411-1.417 diameters.

John Seim
Irvine, CA

leaks
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $11.47
> Forums: http://www.team.net/forums

[email-masked]