Subject: Re: [Mg-t] Petrol Screen Filter

From: John Seim <[email-masked]>
Date: Fri, 13 Sep 2013 05:51:25 -0700

McMaster-Carr sells the screen, as a roll, with an end. You just have to
figure out what size diameter
that you require.
http://www.mcmaster.com/#

John Seim
Irvine, CA

> -------- Original message --------
> From: ImOZ <[email-masked]>
> Date: 09/12/2013  9:12 PM  (GMT-06:00)
> To: [email-masked]
> Subject: [Mg-t] Petrol Screen Filter
>
> Listers,
>
> Recently my TF suddenly would not start.  After much electrical system
> trouble shooting, I found there was little or no gas getting to the carbs.
>
> The gas tank and fuel lines were reinstalled during restoration without the
> mesh screen that protects against debris. In lieu of that, I cut the fuel
> line and installed a modern, clear fuel filter.
>
> This seemed OK until recently.B  Significant debris had accumulated in the
> filter.  Not a huge problem, I changed the filter.
>
> However, no fuel would enter the line.  I siphoned the fuel from the tank
> (or most of it), and removed the fitting at the bottom of the tank.
>
> By means foul or fair, a small round soft ball the consistency of rubber
> cement rubbed off one's fingers had caught in the fitting exiting the tank,
> blocking the flow of fuel.
>
> I found several others like it when the last gush of petrol exited the tank
> into my catch-pan. I tried cleaning the tank as best I could in situ, and
> then hoped there were no more.
>
> Sorry, too bad, the engine choked about 25 miles later, and had to be towed
> home. I presume another little rubbery ball has blocked the orifice to the
> fuel line.
>
> I would be grateful for any advice on how to assure the tank is totally rid
> of such debris.
>
> But for the rest of the season, I would prefer to get a new screen brazed
> onto the brass fitting, or even better, procure a fitting intact with
screen
> filter. I see that it is not available from Moss.
>
> Can anyone refer me to a source for that bit, or offer advice on procuring
> and fastening a substitute screen? I believe such an arrangement will block
> any further foreign matter left in the tank until I can properly treat the
> inside of the tank.
>
> Thank you in advance for your advice.
>
> Dan
> 54 TF
> ______________________________________________
>
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donationB  $11.47
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/mg-t/[email-masked]
______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: "lawrie" <[email-masked]>
Date: Fri, 13 Sep 2013 05:43:36 -0800

But why on earth go to all that trouble when Moss does sell a new adapter with correct mesh screen installed already for only $26.95? Moss part number 376-665.

Lawrie

>  -------Original Message-------
>  From: Rick Lindsay <[email-masked]>
>  To: [email-masked], [email-masked]
>  Subject: Re: [Mg-t] Petrol Screen Filter
>  Sent: 13 Sep '13 03:39
>  
>  Dan, a screen could be fabricated from bulk copper or brass screen wire, usually available at hardware stores. It has larger 'openings' but that's okay because you only want to trap the bigger stuff; the inline filter catching the fine debris. Both copper and brass can easily be soldered so you could make and install the new filter yourself at home. Hope this helps.B
>  
>  -rick
>  Sent from my Samsung Galaxy SIII - the rectangle with rounded corners, just like a BlackBerry.
>  
>  Recently my TF suddenly would not start.B  After much electrical system
>  trouble shooting, I found there was little or no gas getting to the carbs.B  
>  
>  
>  
>  mesh screen that protects against debris.B  In lieu of that, I cut the fuel
>  line and installed a modern, clear fuel filter.B  
>  
>  
>  
>  filter.B  Not a huge problem, I changed the filter.B  
>  
>  
>  
>  However, no fuel would enter the line.B  I siphoned the fuel from the tank
>  (or most of it), and removed the fitting at the bottom of the tank.B  
>  
>  
>  
>  blocking the flow of fuel.B  
>  
>  
>  
>  into my catch-pan.B  I tried cleaning the tank as best I could in situ, and
>  then hoped there were no more.B  
>  
>  
>  
>  home.B  I presume another little rubbery ball has blocked the orifice to the
>  fuel line.B  
>  
>  
>  
>  of such debris.B  
>  onto the brass fitting, or even better, procure a fitting intact with screen
>  filter.B  I see that it is not available from Moss.B  
>  
>  
>  
>  and fastening a substitute screen?B  I believe such an arrangement will block
>  inside of the tank.B  
>  Thank you in advance for your advice.B  
>  
>  
>  
>  Dan
>  
>  54 TF
>  Unsubscribe/Manage: http://autox.team.net/mailman/options/mg-t/[email-masked]
>  Suggested annual donation  $11.47
>  Unsubscribe/Manage: http://autox.team.net/mailman/options/mg-t/[email-masked]

[email-masked]

---

From: "ImOZ" <[email-masked]>
Date: Sat, 14 Sep 2013 09:54:50 -0400

Thank you for the several quick and excellent replies.  As always, this list
is invaluable.  

Dan

> Can anyone refer me to a source for that bit, or offer advice on 
> procuring and fastening a substitute screen? I believe such an 
> arrangement will block any further foreign matter left in the tank 
> until I can properly treat the inside of the tank.
>
> Donate: http://www.team.net/donate.html Suggested annual donationB  
> $11.47

[email-masked]
Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/mg-t/[email-masked]
______________________________________________

[email-masked]