Subject: Re: [Mg-t] XPAG ignition timing instability

From: Lawrie <[email-masked]>
Date: Tue, 12 Nov 2013 13:54:01 -0800

Jeff @ Advanced Distributors will do a terrific job for under $200. 
(www.advanceddistributors.com)

Lawrie

On 11/12/2013 1:23 PM, Richard Lindsay wrote:
> Hi Friends,
>
> My '53 TD's XPAG has unstable ignition timing. Its the kind of
> instability caused by worn distributor bits (advance mechanism,
> bushings, etc.). Static timing is set to TDC but it bounces around
> quite a lot at idle. My TR3 had exactly the same problem and a new
> distributor made it rock solid - the timing AND the idle.
>
> Is there a distributor rebuild service that you recommend? Moss has a
> replacement for $470 but its an upgrade, not a one-for-one
> replacement. I don't want to go there AND I don't have the skills or
> tools to rebuild my distributor.
>
> Please help.
>
> -rick
> ______________________________________________
>
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $11.47
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/mg-t/[email-masked]
______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Scott Allen <[email-masked]>
Date: Tue, 12 Nov 2013 17:09:36 -0500

Blair Engle who is a member of this list did mine.  He owns the Classic MG
Shop in Tallahasee and can be reached at [email-masked].  He also
offers several other rebuild services.

However, please be advised when he did mine he had to replace the case as
well as re-bush it.  It's made of pot metal and the shaft will wear an oval
pattern in it over time rather than staying round, causing the back two
cylinders to run rich no matter what adjustment I made.

~Scott
'52 MG

On Tue, Nov 12, 2013 at 4:23 PM, Richard Lindsay
<[email-masked]>wrote:

> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/mg-t/[email-masked]

[email-masked]

---

From: Gene Gillam <[email-masked]>
Date: Tue, 12 Nov 2013 17:10:07 -0600

I believe Blair has fully retired from the MG repair business now.

Gene Gillam
Saucier, MS
[email-masked]

>> tools to rebuild my distributor.
http://autox.team.net/mailman/options/mg-t/[email-masked]
______________________________________________

[email-masked]

---

From: [email-masked]
Date: Tue, 12 Nov 2013 18:29:05 -0500 (EST)

I rebuild & re curve advance in  distributors as well.
Most under $ 200 as well
Powder coatings
Component rebuilding
Custom cylinder head porting
And of course Roller lifter camshaft kits
5 grinds, "A roller cam will always out perform a flat lifter cam of the same
duration!"
and roller rocker arms.
Len Fanelli
Abingdon Performance
914 420 8699

-----Original Message-----
From: Richard Lindsay <[email-masked]>
To: mg-t <[email-masked]>
Sent: Tue, Nov 12, 2013 4:26 pm
Subject: [Mg-t] XPAG ignition timing instability

Hi Friends,

Please help.

-rick

[email-masked]

[email-masked]