Subject: Re: [Mg-t] TD Oil filter

From: John Seim <[email-masked]>
Date: Mon, 4 Aug 2014 09:02:11 -0700

I sell a spin-on adapter for $122.50.
Replaces the oil filter canister. New filters then cost under $10.00.
You would need a new sealing washer set, or anneal the old copper washers.
I also sell an engine oil filter hose set. Pipes fracture; hoses don't.
$140.00 for the set.
Plus shipping.

John Seim
Irvine, CA

On Aug 4, 2014, at 8:56 AM, Wbeech wrote:

> Is there an inexpensive solution to replacing the oil filter, either just
the
> element or conversion, for an older TD?   Engine number 2080.
>
> Looks like Moss or A Spares is going to run $2-300.
>
> Many thanks,
> Bill
> ______________________________________________
>
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $11.47
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/mg-t/[email-masked]
______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Charles Hill <[email-masked]>
Date: Mon, 04 Aug 2014 17:58:11 -0500

Bill,
You say older TD so I guess you have the TC-style throw-away filter 
instead of the replaceable element filter on later cars. If so, Bob 
Grunau makes a very nice adapter that takes common spin-on filter.  His 
products are well-regarded by TC owners.  You can find his contact info 
on this web site /http://www.mg-tabc.org/suppliers.htm
I don't know what he charges now.  I vaguely remember it was around $75 
when I got one for my TC years ago.   It may be the same as item EE131 
in this catalog.  From the Frame Up is another well-regarded supplier in 
the TC community.

Charles Hill

On 8/4/2014 10:56 AM, Wbeech wrote:
> Is there an inexpensive solution to replacing the oil filter, either just the
> Unsubscribe/Manage: http://autox.team.net/mailman/options/mg-t/[email-masked]

[email-masked]

---

From: Bud Krueger <[email-masked]>
Date: Mon, 04 Aug 2014 19:15:03 -0400

See http://www.ttalk.info/Grunau.htm for Bob Grunau's price list.
Bud Krueger
Charles Hill wrote:
> Grunau makes a very nice adapter that takes common spin-on filter.  
> His products are well-regarded by TC owners.  You can find his contact 
> info on this web site /http://www.mg-tabc.org/suppliers.htm
> I don't know what he charges now.  I vaguely remember it was around 
> $75 when I got one for my TC years ago.   It may be the same as item 
> EE131 in this catalog.  From the Frame Up is another well-regarded 
> supplier in the TC community.
>
> Charles Hill
>
>> http://autox.team.net/mailman/options/mg-t/[email-masked]
> http://autox.team.net/mailman/options/mg-t/[email-masked]
>
>

---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com
______________________________________________

[email-masked]