Subject: Re: [Mgs] tachometer with electronic ignition

From: PaulHunt73 <[email-masked]> Xl7/6mT1qtpAoWRGpMylIruBgSM2y0V9eYK9SzcYkbELR1dmwFCVdhcT9q8hTWu23rLrGL2t0rK2oot8tQ9jHdfAnHHD4V/CYgY=
Date: Fri, 9 Jun 2023 11:26:48 +0100

This is a multi-part message in MIME format.
--===============2711996760508631882==
 boundary="------------iUozsE9JVkF5dFtwODcYZ0Y8"
Content-Language: en-GB

This is a multi-part message in MIME format.
--------------iUozsE9JVkF5dFtwODcYZ0Y8
Content-Transfer-Encoding: 8bit

Where are the coil and CSI picking up their 12v supplies from?

The RVI tach is current triggered and wired from the ignition switch 
(not the fusebox) though a pick-up on the tach to the coil +ve and 
pulses through the coil register on the tach.

Prior to 1973 and the RVC tach electronic ignition systems usually needs 
to be powered from the white at the fusebox as the additional current 
from the electronics flowing through the tach pickup can cause 
problems.  However they usually read too high in that case.

FWIW RB cars with ballasted ignition systems also need electronic 
ignition to be powered from the white at the fusebox even though they 
have an RVC tach as the coil +ve is continually switching between 12v 
and 6v and that can confuse the ignition system.

But it sounds like the problem may be more with the tach itself, they 
can be tested if you have an old-fashioned trickle charger as described 
here http://www.mgb-stuff.org.uk/gauges.htm#tachtest

PaulH.

On 09/06/2023 10:24, R. Martin Rogovein wrote:
>
> Hey all,
>
> After 15 years of staring at it in it's parking space, I am almost 
> done with a full mechanical restoration of my 70 B.
>
>
> Engine, overdrive, brakes, steering, suspension, carbs, and more all 
> completely rebuilt.
>
> Loads of new parts.
>
>
> No paint and bodywork yet, but I'll get there.
>
>
> Replaced the points ignition with a CSI electronic unit, wired 
> everything up per their diagram.
>
> Car runs great, but the Tachometer registers nothing.
>
>
> the tach is the RVI unit with three connectors (M and F bullets for 
> 12v from fusebox through tach to coil) and a tongue for switched 12v 
> to the electronics. Ground is though one of the mounting bolts.
>
>
> Is there a wiring trick to get this tach to work with electronic 
> ignition, or do I have to either get a later tach or order one of the 
> conversion boards?
>
> (like this https://spiyda.com/smiths-rvi-rvc-conversion-board.html)
>
>
> thx
>
> -- 
> --------------------------------------------------------
> Israel is the most dramatic country in the world.
> Everybody's engaged. Everybody argues.
> When I leave Israel, I get a little bit bored, you know?
> --Shimon Peres
> --------------------------------------------------------
>
> _______________________________________________
>
> [email-masked]
> Donate:http://www.team.net/donate.html
> Suggested annual donation  $12.75
>
> Archive:http://www.team.net/pipermail/mgs  http://autox.team.net/archive
>
> Unsubscribe:http://autox.team.net/mailman/options/mgs/[email-masked]
--------------iUozsE9JVkF5dFtwODcYZ0Y8
Content-Transfer-Encoding: 8bit

<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body>
    <p>Where are the coil and CSI picking up their 12v supplies from?</p>
    <p><br>
    </p>
    <p>The RVI tach is current triggered and wired from the ignition
      switch (not the fusebox) though a pick-up on the tach to the coil
      +ve and pulses through the coil register on the tach.</p>
    <p><br>
    </p>
    <p>Prior to 1973 and the RVC tach electronic ignition systems
      usually needs to be powered from the white at the fusebox as the
      additional current from the electronics flowing through the tach
      pickup can cause problems.  However they usually read too high in
      that case.</p>
    <p><br>
    </p>
    <p>FWIW RB cars with ballasted ignition systems also need electronic
      ignition to be powered from the white at the fusebox even though
      they have an RVC tach as the coil +ve is continually switching
      between 12v and 6v and that can confuse the ignition system.</p>
    <p><br>
    </p>
    <p>But it sounds like the problem may be more with the tach itself,
      they can be tested if you have an old-fashioned trickle charger as
      described here <a class="moz-txt-link-freetext" href="http://www.mgb-stuff.org.uk/gauges.htm#tachtest">http://www.mgb-stuff.org.uk/gauges.htm#tachtest</a></p>
    <p><br>
    </p>
    <p>PaulH.<br>
    </p>
    <p><br>
    </p>
    <p><br>
    </p>
    <p><br>
    </p>
    <p><br>
    </p>
    <div class="moz-cite-prefix">On 09/06/2023 10:24, R. Martin Rogovein
      wrote:<br>
    </div>
    <blockquote type="cite"
      cite="mid:[email-masked]">
      <meta http-equiv="content-type" content="text/html; charset=UTF-8">
      <style id="bidiui-paragraph-margins" type="text/css">body p { margin-bottom: 0cm; margin-top: 0pt; }</style>
      <p>Hey all, <br>
      </p>
      <p>After 15 years of staring at it in it's parking space, I am
        almost done with a full mechanical restoration of my 70 B.</p>
      <p><br>
      </p>
      <p>Engine, overdrive, brakes, steering, suspension, carbs, and
        more all completely rebuilt.</p>
      <p>Loads of new parts.</p>
      <p><br>
      </p>
      <p>No paint and bodywork yet, but I'll get there.</p>
      <p><br>
      </p>
      <p>Replaced the points ignition with a CSI electronic unit, wired
        everything up per their diagram.</p>
      <p>Car runs great, but the Tachometer registers nothing.</p>
      <p><br>
      </p>
      <p>the tach is the RVI unit with three connectors (M and F bullets
        for 12v from fusebox through tach to coil) and a tongue for
        switched 12v to the electronics. Ground is though one of the
        mounting bolts.<br>
      </p>
      <p><br>
      </p>
      <p>Is there a wiring trick to get this tach to work with
        electronic ignition, or do I have to either get a later tach or
        order one of the conversion boards?</p>
      <p>(like this <a class="moz-txt-link-freetext"
          href="https://spiyda.com/smiths-rvi-rvc-conversion-board.html"
          moz-do-not-send="true">https://spiyda.com/smiths-rvi-rvc-conversion-board.html</a>)</p>
      <p><br>
      </p>
      <p>thx<br>
      </p>
      <pre class="moz-signature" cols="72">-- 
--------------------------------------------------------
Israel is the most dramatic country in the world.
Everybody's engaged. Everybody argues.
When I leave Israel, I get a little bit bored, you know?
--Shimon Peres
--------------------------------------------------------</pre>
      <br>
      <fieldset class="moz-mime-attachment-header"></fieldset>
      <pre class="moz-quote-pre" wrap="">_______________________________________________

<a class="moz-txt-link-abbreviated" href="mailto:[email-masked]">[email-masked]</a>

Archive: <a class="moz-txt-link-freetext" href="http://www.team.net/pipermail/mgs">http://www.team.net/pipermail/mgs</a> <a class="moz-txt-link-freetext" href="http://autox.team.net/archive">http://autox.team.net/archive</a>

Unsubscribe: <a class="moz-txt-link-freetext" href="http://autox.team.net/mailman/options/mgs/[email-masked]">http://autox.team.net/mailman/options/mgs/[email-masked]</a>
</pre>
    </blockquote>
  </body>
</html>

--------------iUozsE9JVkF5dFtwODcYZ0Y8--

--===============2711996760508631882==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________

[email-masked]

Archive: http://www.team.net/pipermail/mgs http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

--===============2711996760508631882==--

---

From: PaulHunt73 <[email-masked]>
Date: Sat, 10 Jun 2023 12:48:20 +0100

This is a multi-part message in MIME format.
--===============3214638925012814533==
 boundary="------------ofcMDFnOMKCk1rbXWLzRktbB"
Content-Language: en-GB

This is a multi-part message in MIME format.
--------------ofcMDFnOMKCk1rbXWLzRktbB
Content-Transfer-Encoding: 7bit

Incidentally if you _do_ have a wire from the fusebox white to the coil 
+ve it's probably bypassing the tach pick-up.

PaulH.

>> (like this https://spiyda.com/smiths-rvi-rvc-conversion-board.html)
--------------ofcMDFnOMKCk1rbXWLzRktbB
Content-Transfer-Encoding: 7bit

<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body>
    <p>Incidentally if you _do_ have a wire from the fusebox white to
      the coil +ve it's probably bypassing the tach pick-up.</p>
    <p>PaulH.</p>
    <p><br>
    </p>
    <div class="moz-cite-prefix">On 09/06/2023 11:26, PaulHunt73 wrote:<br>
    </div>
    <blockquote type="cite"
      cite="mid:[email-masked]">
      <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
      <p>Where are the coil and CSI picking up their 12v supplies from?</p>
      <br>
      <p><br>
      </p>
      <div class="moz-cite-prefix">On 09/06/2023 10:24, R. Martin
        Rogovein wrote:<br>
      </div>
      <blockquote type="cite"
        cite="mid:[email-masked]">
        <meta http-equiv="content-type" content="text/html;
          charset=UTF-8">
        <style id="bidiui-paragraph-margins" type="text/css">body p { margin-bottom: 0cm; margin-top: 0pt; }</style>
        <p>Hey all, <br>
        </p>
        <p>After 15 years of staring at it in it's parking space, I am
          almost done with a full mechanical restoration of my 70 B.</p>
        <p><br>
        </p>
        <p>Engine, overdrive, brakes, steering, suspension, carbs, and
          more all completely rebuilt.</p>
        <p>Loads of new parts.</p>
        <p><br>
        </p>
        <p>No paint and bodywork yet, but I'll get there.</p>
        <p><br>
        </p>
        <p>Replaced the points ignition with a CSI electronic unit,
          wired everything up per their diagram.</p>
        <p>Car runs great, but the Tachometer registers nothing.</p>
        <p><br>
        </p>
        <p>the tach is the RVI unit with three connectors (M and F
          bullets for 12v from fusebox through tach to coil) and a
          tongue for switched 12v to the electronics. Ground is though
          one of the mounting bolts.<br>
        </p>
        <p><br>
        </p>
        <p>Is there a wiring trick to get this tach to work with
          electronic ignition, or do I have to either get a later tach
          or order one of the conversion boards?</p>
        <p>(like this <a class="moz-txt-link-freetext"
            href="https://spiyda.com/smiths-rvi-rvc-conversion-board.html"
            moz-do-not-send="true">https://spiyda.com/smiths-rvi-rvc-conversion-board.html</a>)</p>
        <p><br>
        </p>
        <p>thx<br>
        </p>
        <pre class="moz-signature" cols="72">-- 
--------------------------------------------------------
Israel is the most dramatic country in the world.
Everybody's engaged. Everybody argues.
When I leave Israel, I get a little bit bored, you know?
--Shimon Peres
--------------------------------------------------------</pre>
        <br>
        <fieldset class="moz-mime-attachment-header"></fieldset>
        <pre class="moz-quote-pre" wrap="">_______________________________________________

<a class="moz-txt-link-abbreviated moz-txt-link-freetext" href="mailto:[email-masked]" moz-do-not-send="true">[email-masked]</a>

Archive: <a class="moz-txt-link-freetext" href="http://www.team.net/pipermail/mgs" moz-do-not-send="true">http://www.team.net/pipermail/mgs</a> <a class="moz-txt-link-freetext" href="http://autox.team.net/archive" moz-do-not-send="true">http://autox.team.net/archive</a>

Unsubscribe: <a class="moz-txt-link-freetext" href="http://autox.team.net/mailman/options/mgs/[email-masked]" moz-do-not-send="true">http://autox.team.net/mailman/options/mgs/[email-masked]</a>
</pre>
      </blockquote>
    </blockquote>
  </body>
</html>

--------------ofcMDFnOMKCk1rbXWLzRktbB--

--===============3214638925012814533==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============3214638925012814533==--

---

From: "R. Martin Rogovein" <[email-masked]>
Date: Sat, 24 Jun 2023 10:44:10 +0300

This is a multi-part message in MIME format.
--------------KVIATqHPxLFT0rY80wuPl0c1
Content-Transfer-Encoding: 8bit

<html style="direction: ltr;">
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body bidimailui-charset-is-forced="true" style="direction: ltr;">
    <p>Hey Paul <br>
    </p>
    <p>Haven't had the tach out to try and bench test it, that'll take a
      little doing.</p>
    <p>but meanwhile everything is wired according to the attached
      diagram (left side diagram).</p>
    <p>Engine runs smooth, but the tach currently shows no response at
      all (needle doesn't even bounce on start).<br>
    </p>
    <p><br>
    </p>
    <p>If i understand correctly, taking the red from the + of the coil
      to the CSI (as shown) could cause interference with the old style
      tach, and it might work (but read high) if i were to take that red
      to the CSI from some other switched 12v and not through the tach?<br>
    </p>
    <p><br>
    </p>
    <p><br>
    </p>
    <p><br>
    </p>
    <div class="moz-cite-prefix">On 09/06/2023 13:26, PaulHunt73 wrote:<br>
    </div>
    <blockquote type="cite"
      cite="mid:[email-masked]">
      <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
      <p>Where are the coil and CSI picking up their 12v supplies from?</p>
      <p><br>
      </p>
      <p>The RVI tach is current triggered and wired from the ignition
        switch (not the fusebox) though a pick-up on the tach to the
        coil +ve and pulses through the coil register on the tach.</p>
      <p><br>
      </p>
      <p>Prior to 1973 and the RVC tach electronic ignition systems
        usually needs to be powered from the white at the fusebox as the
        additional current from the electronics flowing through the tach
        pickup can cause problems.  However they usually read too high
        in that case.</p>
      <p><br>
      </p>
      <p>FWIW RB cars with ballasted ignition systems also need
        electronic ignition to be powered from the white at the fusebox
        even though they have an RVC tach as the coil +ve is continually
        switching between 12v and 6v and that can confuse the ignition
        system.</p>
      <p><br>
      </p>
      <p>But it sounds like the problem may be more with the tach
        itself, they can be tested if you have an old-fashioned trickle
        charger as described here <a class="moz-txt-link-freetext"
          href="http://www.mgb-stuff.org.uk/gauges.htm#tachtest"
          moz-do-not-send="true">http://www.mgb-stuff.org.uk/gauges.htm#tachtest</a></p>
      <p><br>
      </p>
      <p>PaulH.<br>
      </p>
      <p><br>
      </p>
      <p><br>
      </p>
      <p><br>
      </p>
      <p><br>
      </p>
      <div class="moz-cite-prefix">On 09/06/2023 10:24, R. Martin
        Rogovein wrote:<br>
      </div>
      <blockquote type="cite"
        cite="mid:[email-masked]">
        <meta http-equiv="content-type" content="text/html;
          charset=UTF-8">
        <style id="bidiui-paragraph-margins" type="text/css">body p { margin-bottom: 0cm; margin-top: 0pt; }</style>
        <p>Hey all, <br>
        </p>
        <p>After 15 years of staring at it in it's parking space, I am
          almost done with a full mechanical restoration of my 70 B.</p>
        <p><br>
        </p>
        <p>Engine, overdrive, brakes, steering, suspension, carbs, and
          more all completely rebuilt.</p>
        <p>Loads of new parts.</p>
        <p><br>
        </p>
        <p>No paint and bodywork yet, but I'll get there.</p>
        <p><br>
        </p>
        <p>Replaced the points ignition with a CSI electronic unit,
          wired everything up per their diagram.</p>
        <p>Car runs great, but the Tachometer registers nothing.</p>
        <p><br>
        </p>
        <p>the tach is the RVI unit with three connectors (M and F
          bullets for 12v from fusebox through tach to coil) and a
          tongue for switched 12v to the electronics. Ground is though
          one of the mounting bolts.<br>
        </p>
        <p><br>
        </p>
        <p>Is there a wiring trick to get this tach to work with
          electronic ignition, or do I have to either get a later tach
          or order one of the conversion boards?</p>
        <p>(like this <a class="moz-txt-link-freetext"
            href="https://spiyda.com/smiths-rvi-rvc-conversion-board.html"
            moz-do-not-send="true">https://spiyda.com/smiths-rvi-rvc-conversion-board.html</a>)</p>
        <p><br>
        </p>
        <p>thx<br>
        </p>
        <pre class="moz-signature" cols="72">-- 
--------------------------------------------------------
Israel is the most dramatic country in the world.
Everybody's engaged. Everybody argues.
When I leave Israel, I get a little bit bored, you know?
--Shimon Peres
--------------------------------------------------------</pre>
        <br>
        <fieldset class="moz-mime-attachment-header"></fieldset>
        <pre class="moz-quote-pre" wrap="">_______________________________________________

Unsubscribe: <a class="moz-txt-link-freetext" href="http://autox.team.net/mailman/options/mgs/[email-masked]">http://autox.team.net/mailman/options/mgs/[email-masked]</a>
</pre>
    </blockquote>
    <pre class="moz-signature" cols="72">-- 
--------------------------------------------------------
Israel is the most dramatic country in the world.
Everybody's engaged. Everybody argues.
When I leave Israel, I get a little bit bored, you know?
--Shimon Peres
--------------------------------------------------------</pre>
  </body>
</html>
--------------KVIATqHPxLFT0rY80wuPl0c1
Content-Disposition: attachment; filename="20230624_103238.jpg"
Content-Transfer-Encoding: base64

--------------KVIATqHPxLFT0rY80wuPl0c1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--------------KVIATqHPxLFT0rY80wuPl0c1--

---

From: PaulHunt73 <[email-masked]> BzNqwh9XgHOIvALWSv20590mKiZ/w0zDUm5DMfQmWlfigMlmasuRcG2NLu9Bn/y0l4x/bdyoDbKiT/DRknHx6mpAJuvS7i48AUg=
Date: Mon, 26 Jun 2023 08:35:42 +0100

I suspect the problem is at the tach itself.  Wired as per that diagram 
where the electronic ignition picks up it's 12v supply from the coil +ve 
i.e. via the RVI tach is when you can get over-reading, it's always best 
to power them from the white at the fusebox where the RVI is concerned.  
Ironically it's also best to do that with RB cars even though they have 
the later RVC tach due to the lowered voltage at the coil +ve.

However first thing to confirm is that the ignition _is_ being powered 
via the RVI tach, and to do that remove either of the white wires from 
the back of the tach with the engine running and it should stop.  If it 
doesn't then the coil is being supplied from somewhere else and the tach 
is being bypassed.  I accept  it may not be easy to get at the tach but 
it will have to be done sometime.

If the engine does stop then reconnect it, and check you have 12v on the 
spade terminal on the back of the tach (green wire) and an earth going 
to the case, which is usually a black wire under one of the knurled 
fixing screws, with the ignition on.

If you have both of those then either the tach electronics or internal 
connections are faulty, or maybe the needle is stuck.  So before doing 
anything else, with the engine revving at about 2k or so give the glass 
a sharp rap with a knuckle.

PaulH.

On 24/06/2023 08:44, R. Martin Rogovein wrote:
>
> Hey Paul
>
> Haven't had the tach out to try and bench test it, that'll take a 
> little doing.
>
> but meanwhile everything is wired according to the attached diagram 
> (left side diagram).
>
> Engine runs smooth, but the tach currently shows no response at all 
> (needle doesn't even bounce on start).
>
>
> If i understand correctly, taking the red from the + of the coil to 
> the CSI (as shown) could cause interference with the old style tach, 
> and it might work (but read high) if i were to take that red to the 
> CSI from some other switched 12v and not through the tach?
>
>
>
>

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.75