Subject: Re: [Mgs] windshield seal installation

From: Larry Colen <[email-masked]>
Date: Tue, 7 Nov 2023 14:42:03 -0800

I don't know if this works on MGBs, I only did it on my cortina, when I had my MGB windshield replaced, insurance covered the installation, but...

Do you know "the rope trick"?  Where you put the seal on the window, put a rope on the other side of the seal, put the window in place, and by pulling the rope through the window it pulls the seal into place.

I'm sure there are now better descriptions online.  It may also help to use some sort of lube on the rubber and windshield frame.

> On Nov 7, 2023, at 1:57 PM, David Councill <[email-masked]> wrote:
> 
> Has anyone installed the windshield frame to body seal (AHH7136 or Moss 282-410) recently? I ordered the seal 1-2 years ago from Moss, and it is a URO product. Many attempts later, I have only managed to get the initial three inches to stay in the rails, the rest popping out after several inches more of seal in place. I have seen youtube videos as well as other Internet materials. Some say start in the  middle, some say start at the end, some says push/pull the seal through after removing a side pillar (which I haven't tried yet). I have tried soap as well as wd-40 as a lubricant.
> 
> So now I am wondering if it is the seal itself due to the hardness of the rubber - which is true. I have to press fairly hard to get the initial one side of the "T" in the slot before I press in the opposing side. Does anyone know about issues with the URO seal such that I should purchase a different seal from McGregors or elsewhere? Or is it still in the technique?
> 
> David Councill
> 
> 72 B
> 
> _______________________________________________
> 
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.75
> 
> Archive: http://www.team.net/pipermail/mgs http://autox.team.net/archive
> 
> Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]
> 

--
Larry Colen
[email-masked]  sent from ret13est

_______________________________________________

[email-masked]

Archive: http://www.team.net/pipermail/mgs http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: Paul Hunt <[email-masked]>
Date: Wed, 8 Nov 2023 08:20:38 +0000

Unless it's actually damaged it's one of those things that is best left 
alone and not touched for cosmetic reasons.

It will be mostly down to the rubber, after that technique.  Two of the 
latter I'm aware of - push-pull and the one John Twist shows where it is 
levered in with a hooked tool bit by bit 
https://www.youtube.com/watch?v=TTJ-A_-n0_o  Both need lubrication, and 
patience.

Compare the width of the crossbar on the 'T' with the width of the 
slot.  If the rubber is wider then it's likely to be bowed instead of 
lying flat and pop out that way.  If it's narrower then it'll pop out 
anyway.

PaulH

On 07/11/2023 21:57, David Councill wrote:
> Has anyone installed the windshield frame to body seal (AHH7136 or 
> Moss 282-410) recently? I ordered the seal 1-2 years ago from Moss, 
> and it is a URO product. Many attempts later, I have only managed to 
> get the initial three inches to stay in the rails, the rest popping 
> out after several inches more of seal in place. I have seen youtube 
> videos as well as other Internet materials. Some say start in the  
> middle, some say start at the end, some says push/pull the seal 
> through after removing a side pillar (which I haven't tried yet). I 
> have tried soap as well as wd-40 as a lubricant.
>
> So now I am wondering if it is the seal itself due to the hardness of 
> the rubber - which is true. I have to press fairly hard to get the 
> initial one side of the "T" in the slot before I press in the opposing 
> side. Does anyone know about issues with the URO seal such that I 
> should purchase a different seal from McGregors or elsewhere? Or is it 
> still in the technique?
>
> David Councill
>
> 72 B
>
> Unsubscribe: 
> http://autox.team.net/mailman/options/mgs/[email-masked]

[email-masked]