Subject: Re: [Tigers] Aluminum Radiator

From: Alexander Washick <[email-masked]>
Date: Tue, 5 Mar 2013 23:34:18 -0500

Brent   Where did you get this radiator? I don't even see that they list
one for a Tiger. Was it custom made? I have a aluminum radiator that is
from Dale's Restorations in Cal.and it fits perfect and solved all of my
cooling problems and I run a mildly modified 302 with air conditioning on a
daily basis and I live in Florida. Many believe that his is same as
Griffin's but that is not the case for many years. He designed his own they
are made for him. It is a great product and out performs the Griffin! How
do I know? A few years ago, I called Dale to see if he had a Griffin and I
didn't want to wait for the Griffin to be made to order. He took the time
to explain what differences were and it sure proved right for me as I had
used all the cooling mods listed on Tigers United and others and was still
having big problems!! If this Fluidyne was made to fit your car and doesn't
then I would send it back and talk to Dale.  Al

On Mon, Mar 4, 2013 at 11:33 PM, Brent Edinger <[email-masked]> wrote:

> I just installed an aluminum Fluidyne radiator and when it came time
> to install the fan shroud I found the thickness of the new radiator
> won't allow it to be installed. There is about a half inch gap between
> the fwd edge of the shroud and the aft edge of the radiator support,
> Any tricks to this? I built a little splice plate and It's installed but it
> doesn't look good and I can see air will leak around over the top of the
> radiator.
>
>           Brent
> _______________________________________________
>
> [email-masked]
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe:
> http://autox.team.net/mailman/options/tigers/[email-masked]
_______________________________________________

[email-masked]

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

---

From: Sandy Ganz <[email-masked]>
Date: Wed, 6 Mar 2013 13:23:10 -0800 (PST)

Fluidyne hasen't made the radiator for the Tiger in a number of years. I got
lucky can got one from someone NIB off of EPay for mid $300's and was glad to
get it. It's a very thick radiator, and the one that I have is a 2 pass
radiator. I do not have it in the car now but it will go in with the new motor
some day. I have the Griffin in the car now and it's a nice radiator better
then 
stock, but looks to have much less cooling capacity then the Fluidyne
and much 
less substantial in the manufacturing area. The Griffin fit without
much trouble 
and seems to work fine with the stock 260 that's in the car. I
did not run a 
shroud on the Griffin, but I think it would fit without much
trouble but I think 
it would be needed if I really drove the car more. I was
just too lazy to put it 
on.

I don't know how the shroud fits on the fluidyne
but I would imagine it might 
take more work to make it fit given the
different dimension. That being said I 
have only looked at it in the box so
might be a more or less work. Also I think 
one other place that makes custom
radiators in Arizona (Davis???) has one for 
the Tiger but can't rember the
name, it was like $600+ as I recall and weeks to 
fab.  I have run
various Fluidyne radiators in my other car and they are well 
made product and
if you have the 2 pass model it's a good one but not sure if 
other styles
were made.

Sandy

----- Original Message ----
From: Alexander Washick
<[email-masked]>
To: Brent Edinger <[email-masked]>
Cc:
"[email-masked]" <[email-masked]>
Sent: Wed, March 6, 2013
1:03:47 PM
Subject: Re: [Tigers] Aluminum Radiator

Brent  Where did you get
this radiator? I don't even see that they list
one for a Tiger. Was it custom
made? I have a aluminum radiator that is
from Dale's Restorations in Cal.and
it fits perfect and solved all of my
cooling problems and I run a mildly
modified 302 with air conditioning on a
daily basis and I live in Florida.
Many believe that his is same as
Griffin's but that is not the case for many
years. He designed his own they
are made for him. It is a great product and
out performs the Griffin! How
do I know? A few years ago, I called Dale to see
if he had a Griffin and I
didn't want to wait for the Griffin to be made to
order. He took the time
to explain what differences were and it sure proved
right for me as I had
used all the cooling mods listed on Tigers United and
others and was still
having big problems!! If this Fluidyne was made to fit
your car and doesn't
then I would send it back and talk to Dale.  Al

On Mon,
Mar 4, 2013 at 11:33 PM, Brent Edinger <[email-masked]> wrote:

> I just
installed an aluminum Fluidyne radiator and when it came time
> to install the
fan shroud I found the thickness of the new radiator
> won't allow it to be
installed. There is about a half inch gap between
> the fwd edge of the shroud
and the aft edge of the radiator support,
> Any tricks to this? I built a
little splice plate and It's installed but it
> doesn't look good and I can
see air will leak around over the top of the

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe:
http://autox.team.net/mailman/options/tigers/[email-masked]
_______________________________________________

[email-masked]

---

From: Brent Edinger <[email-masked]>
Date: Wed, 6 Mar 2013 14:13:42 -0800

I just bought the Fluidyne 2 weeks ago from Dale. It fits good except that it
is thicker
and the shroud won't fit up to the radiator core support. I put spacers on the
bottom
2 bolts but the top is 1/2 inch short of lining up with the screw hole. I'm
going
to fabricate some kind of plate to attach it to and blank off the gap. Running
a
high hp motor doesn't work well without the shroud.

   Brent

> Date: Wed, 6 Mar 2013 13:23:10 -0800
> From: [email-masked]
> To: [email-masked]; [email-masked]
> CC: [email-masked]
>
then
> stock, but looks to have much less cooling capacity then the Fluidyne and
much
> less substantial in the manufacturing area. The Griffin fit without much
trouble
> and seems to work fine with the stock 260 that's in the car. I did not run a
> shroud on the Griffin, but I think it would fit without much trouble but I
think
> it would be needed if I really drove the car more. I was just too lazy to
put it
> on.
>
> I don't know how the shroud fits on the fluidyne but I would imagine it
might
> take more work to make it fit given the different dimension. That being said
I
> have only looked at it in the box so might be a more or less work. Also I
think
> one other place that makes custom radiators in Arizona (Davis???) has one
for
> the Tiger but can't rember the name, it was like $600+ as I recall and weeks
to
> fab.  I have run various Fluidyne radiators in my other car and they are
well
> made product and if you have the 2 pass model it's a good one but not sure
if
> other styles were made.
> From: Alexander Washick <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Sent: Wed, March 6, 2013 1:03:47 PM
> Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

[email-masked]

---

From: "Buck Trippel" <[email-masked]>
Date: Thu, 07 Mar 2013 10:29:00 -0800

Actually Sandy, Fuidyne recently started making batches of aluminum 
radiators for Dale. Dale sells them for $550. The radiators are the stock 
configuration and can be painted black for those who want the stock look. 
Internally they have a new 3 row core that is about 2" thick in the fan 
area.

When I last spoke to Dale he also had some of the radiators from the 
previous vendor still available.

Buck Trippel

----- Original Message ----- 
From: "Sandy Ganz" <[email-masked]>
To: "Alexander Washick" <[email-masked]>; "Brent Edinger" 
<[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, March 06, 2013 1:23 PM
Subject: Re: [Tigers] Aluminum Radiator

[email-masked]