Subject: [DMVR] Airbags and Helmets

From: [email-masked]
Date: Wed, 17 Nov 2004 13:53:43 EST

Looks like full face helmets and airbag equipped cars will soon be verboten:

http://www.scca.com/_Filelibrary/File/AirbagAdvisory.pdf

Bart

---

From: Chanda Hufford <[email-masked]>
Date: Wed, 17 Nov 2004 11:56:30 -0800 (PST)

Well crap. I always thought I was more protected from
the airbag with my full face helmet. Guess I'll have
to get a super cheap open face or something. I hate
borrowing helmets ;)

Chanda

> 
> Bart
> _______________________________________________
> DMVR mailing list
> [email-masked]
> http://www.team.net/mailman/listinfo/dmvr
> 

=====
~*1996 Plymouth ACR Sedan*~
"Wahoo" / 107,000 Miles / #4 in STSL
-->2003 Buell Blast<--
"The Purple Cricket" / 2,300 miles :)

__________________________________ 
Do you Yahoo!? 
The all-new My Yahoo! - Get yours free! 
http://my.yahoo.com

---

From: "Dan Slater" <[email-masked]>
Date: Wed, 17 Nov 2004 14:49:27 -0600 (CST)

I think we may want to get that into drifting right away just so it gives
people a little warning for next year.

Dan Slater
Slater Racing
DMVRSCCA Solo Activities Director
http://www.slateracing.com
http://www.dmvrscca.org
"The truth is - I have a problem. I'm addicted to cars. " - Tim Allen as
Tim Taylor (Home Improvement)

---

From: Sam & Greg Scharnberg <[email-masked]>
Date: Wed, 17 Nov 2004 14:51:21 -0600

I was thinking a leather one with goggles would be nice!

Greg

PS:  I don't think that "Snell" and "cheap" go together very well.

---

From: Sam & Greg Scharnberg <[email-masked]>
Date: Wed, 17 Nov 2004 15:06:54 -0600

Just be sure it's understood that they are "just talking about it".  Don't 
want folks to invest in a new closed helmet, but they MAY be OK for years 
to come.  Who knows!

Greg

---

From: Chanda Hufford <[email-masked]>
Date: Wed, 17 Nov 2004 17:54:42 -0800 (PST)

Yea, that's the only downfall. Eh, who knows? :)

Chanda

--- Sam & Greg Scharnberg <[email-masked]>

=====

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: "Mike Slater" <[email-masked]>
Date: Wed, 17 Nov 2004 20:56:44 -0600

I am glad I stuck with the Open face, I don't have to worry about getting
another helmet for a while.

However, I think the Club WILL need to get a few to make sure we don't have
problems because of that with OUR Loaner helmets.

Mike Slater