Subject: [DMVR] Look who is pictured here

From: "Chris Paris" <[email-masked]>
Date: Wed, 2 Jun 2004 21:14:44 -0500

Way to go Jarrod . . .

http://www.automotivemachineshop.com/chassis_dyno.shtml

---

From: "Jarrod Igou" <[email-masked]>
Date: Thu, 03 Jun 2004 09:07:06 -0500

Guess I can't deny I've dyno'ed the car now, huh?

That's a whole big bunch of angry gerbils on display there--

Wonder if I can get discount pricing on a return visit??  

Jarrod

On 2 Jun 2004 at 21:14, Chris Paris wrote:

> _______________________________________________
> DMVR mailing list
> [email-masked]
> http://www.team.net/mailman/listinfo/dmvr