Subject: [DMVR] The 2005 ARRC Report.....

From: [email-masked]
Date: Mon, 14 Nov 2005 14:33:07 EST

....form the Spec Miata Perspective

No worries though.......old #9 came through without any (new)  damage.

---

From: Ric Johnson <[email-masked]>
Date: Mon, 14 Nov 2005 21:22:16 -0600

>....form the Spec Miata Perspective

Unfortunately the DMVR Email list does not allow photos so folks missed the 
humorous part of your note as the pic was deleted.

Ric