Subject: [JAGNUTS] Majestics

From: "mini.sales" <[email-masked]>
Date: Mon, 22 Mar 2004 12:48:52 -0600

Hi Guys. Richard Swallow here from MINI Sales.
I don't know if I could put a new MINI there or not??
What do you guys think or know?????

Richard Swallow 
sales rep 
MINI Regina

---

From: "Bob" <[email-masked]>
Date: Mon, 22 Mar 2004 21:50:23 -0600

Richard. Best to check with the organizers.  Bob

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of mini.sales
Sent: March 22, 2004 12:49 PM
To: [email-masked]
Subject: [JAGNUTS] Majestics

Richard Swallow
sales rep
MINI Regina