Subject: [JAGNUTS] FW: June's Open Road

From: "Bob" <[email-masked]>
Date: Wed, 22 May 2013 14:02:20 -0600

From: Howard Jewell [mailto:[email-masked]] 
Sent: May 22, 2013 1:13 PM
To: Undisclosed-recipients:
Subject: June's Open Road 

Attached is the link for June's Open Road:

https://www.box.com/s/lz19wemoxtwtk2x471jk

Cheers,

Howard Jewell

[email-masked]

This is an exchange newsletter we ask that you do not forward this on unless
it is to further foster exchange.  Thank you

---

From: "Bob" <[email-masked]>
Date: Wed, 4 Jun 2014 11:13:32 -0600

>From Edmonton ...

From: Howard Jewell [mailto:[email-masked]] 
Sent: June 3, 2014 11:29 PM
To: Undisclosed-recipients:
Subject: June's Open Road

Below is the link for the Edmonton Classic Sports Car Club's Open Road
finally. 

https://app.box.com/s/omyhq3id56oca3098816

Cheers and enjoy, 

Howard Jewell

[email-masked]